More in this section

Forums / Bugs & Issues / Can't add a field into a Module

Can't add a field into a Module

1 posts, 0 answered
  1. Mike
    Mike avatar
    11 posts
    Registered:
    03 May 2012
    27 Jun 2012
    Link to this post
    Hi,

    We have two modules to handle custom Events and Competitions. We built these modules a week ago but now need to add some extra fields to them.

    When trying to add fields we get an error in the Module Builder:

    Looking at the "e2e" debug file from the web service shows us the source error:
    Query execution did not find a matching element.
    at
    Telerik.OpenAccess.Query.ExpressionExecution.PerformQuerySingle[T,TResult](QueryableCategory before, Expression expression, Boolean tryGetObjectById, ExecutionSettings settings)
    Telerik.OpenAccess.Query.Piece`1.ExecuteSingle[TResult](Expression expression)

    We *did* have a classification field in there but it has been removed (it was removed OK).

    The field list is:
    CompetitionDate Date and Time
    Name Short text 
    CompetitionIcon Media (images, videos, files)
    ClosingDate Date and Time
    CompetitionBannerImage Media (images, videos, files)
    CompetitionFullImage Media (images, videos, files)
    PreHeadlineShort text
    HeadlineShort text
    SubHeadlineShort text
    CompetitionContentHeadingShort text
    ShortContentShort text
    ContentLong text

    I have seen another post on here that the Module Builder doesn't work properly, but simply we need a functioning product!
    http://www.sitefinity.com/devnet/forums/sitefinity-4-x/developing-with-sitefinity/module-builder-broken-what-now.aspx 

    Any ideas please?!
    Andy
1 posts, 0 answered