More in this section

Forums / Bugs & Issues / Custom field with selection of multiple choices

Custom field with selection of multiple choices

10 posts, 0 answered
  1. Waqar
    Waqar avatar
    16 posts
    Registered:
    23 Nov 2010
    20 May 2011
    Link to this post
    HI All!

    I want to extend sitefinity 4.x Document & Files Module and want to add a custom field, In this custom field option I want to show a number of check boxes where user can check multiple check boxes.
    The selected check boxes values should be accessible, which I can use in my front end  controls.

    Please let me know how it is possible. I tried but It saved only one selected value not mutiple. The error on mutiple selection is attached in Image.

    any suggestion ?

    Thanks in Advance.
  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    12 Sep 2017
    20 May 2011
    Link to this post
    Hi waqar,

    We need to see how you bind your control and what are the values you use. The code you added breaks the entire content item. Make sure that you use correct types for the custom field. You should pass the selected values as json.

    Best wishes,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. waqar
    waqar avatar
    76 posts
    Registered:
    28 Mar 2011
    20 May 2011
    Link to this post
    Thanks for the reply.

    You can find the details at the link given below.

    http://www.sitefinity.com/devnet/forums/sitefinity-4-x/general-discussions/checkboxes-custom-field-in-documents-files-module.aspx

    Please tell me how can I achieve this functionality asap.
    Thanks!
  4. John
    John avatar
    17 posts
    Registered:
    03 Mar 2008
    23 May 2011
    Link to this post
    I am getting worse problem...... i Added 2 multichoices custom field and select INT and INTEGER data TYPE because i wanted  to get numerical value from the radio buttons user selects. The process were successfull but then  when i clicked on Content => Blogs...Sitefinity Crashed and giving me error kind of ...... fail to convert string to int ..etc etc......
    i am still trying to figure it out on how to remove 2 custom fields i had created..because i even could get into Blog Content..( it crashed evertime i tried to get into it ).....HELP PLEASE....at least tell me how to remove those 2 custom fields by code...otherwise i am screwed !
  5. waqar
    waqar avatar
    76 posts
    Registered:
    28 Mar 2011
    23 May 2011
    Link to this post
    Hello John!

    Not a problem dear, same thing happened with me many times while I was learning it. What you need to do is,
    1- Goto the sitefinity database search the tables that contains column name and text in tables with name you created the fields. (SQL query for search text and column name from a database is available on internet )
     2- Goto the App_data --> Sitefinity --> Configuration here you will find a number of xml configuration files. You have to find and delete the fields you created. With this there are many xml configurations files in the folder which are not included in the project so you have to open it into windows explorer and search the filed you created by text and delete them too.
    3- Save, build your project and login again. Hope this will work for you too.
    ---Remember to backup your project files and database as well.

    Hope this will work for you as well OR wait for 2 days to get sitefinity team reply.

    Regards!


  6. John
    John avatar
    17 posts
    Registered:
    03 Mar 2008
    23 May 2011
    Link to this post
    I have searched BlogsConfig.config to workflowConfig.config..searching "ServiceLines" and "Industry" custom field i created....but none.....
  7. waqar
    waqar avatar
    76 posts
    Registered:
    28 Mar 2011
    23 May 2011
    Link to this post
    Ok jhon,

    Would you like to send me your web application and database at mwaqarhaider@gmail.com ? I can do this for you.

    Its my pleasure to help you on this :-)

    regards!
  8. waqar
    waqar avatar
    76 posts
    Registered:
    28 Mar 2011
    24 May 2011
    Link to this post
    Would you like to reply? Sitefinity Team?
  9. John
    John avatar
    17 posts
    Registered:
    03 Mar 2008
    24 May 2011
    Link to this post
    finally i did it...by following waqar advice...i deleted the field on the tables...thanks
  10. waqar
    waqar avatar
    76 posts
    Registered:
    28 Mar 2011
    24 May 2011
    Link to this post
    Thats gud dude :-)

    But What about my problem? sitefinity team is not helping out me. I am hanged up at this point since last week. I have posted the issue in more than 8 posts but no reply from sitefinity team.

    Lets see when sitefinity team will hear me, but its nice to hear from you JHON.

    Regards!
10 posts, 0 answered