More in this section

Forums / Bugs & Issues / Deleting a module from Sitefinity 4.0 RC

Deleting a module from Sitefinity 4.0 RC

2 posts, 0 answered
  1. John Tolar
    John Tolar avatar
    87 posts
    Registered:
    07 May 2003
    22 Dec 2010
    Link to this post
    When you go to Administration->Settings->advanced->system->application modules and delete a module. the module still appears in the menus. This occurs even after the application pool, website and web server has been restarted.

    The only way I have seen is to replace the module and remove the menu keys manually in the install virtual method.

    Is there a override missing for the deletion of a module? 

    Also, How do you upgrade a module? I have seen put code in the upgrade virtual method but the code never gets hit.

    Also, Is there a way to register the module when it gets put into the application modules section without restarting the website or app pool?

    Thanks,

    JT
  2. Hristo Borisov
    Hristo Borisov avatar
    190 posts
    Registered:
    19 Jun 2017
    23 Dec 2010
    Link to this post
    Hi John Tolar,

    Method for deleting a module is in our backlog list. You are already using the workaround of uninstalling the data from the install method. We are aware that this is not convenient and imposes number of problems and we will do our best to resolve that as soon as possible based on its priority.

    Thank you for pointing that, and thank you for spending the time to evaluate our RC2 release. If you have any other questions, please let me know.

    Best wishes,
    Hristo Borisov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
2 posts, 0 answered