More in this section

Forums / Bugs & Issues / Error While running site from IIS

Error While running site from IIS

3 posts, 0 answered
  1. Dhaval
    Dhaval avatar
    21 posts
    23 Apr 2012
    24 Apr 2012
    Link to this post

    Server Error in '/' Application.

    Configuration Error

    Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

    Parser Error Message: It is an error to use a section registered as allowDefinition='MachineToApplication' beyond application level.  This error can be caused by a virtual directory not being configured as an application in IIS.

    Source Error:

    Line 85:     <customErrors mode="Off" defaultRedirect="~/error.aspx" redirectMode="ResponseRewrite"/>
    Line 86:     <compilation debug="true" targetFramework="4.0"/>
    Line 87:     <roleManager enabled="true" cacheRolesInCookie="true" defaultProvider="Sitefinity">
    Line 88:       <providers>
    Line 89:         <clear/>

    Source File: c:\inetpub\wwwroot\salix update\salix\web.config    Line: 87

    Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.0.30319.237
  2. Randy Hodge
    Randy Hodge avatar
    96 posts
    03 Nov 2014
    01 May 2012
    Link to this post
    Hi, Dhaval.

    Thank you for contacting us.

    There are several possible causes for this error.
    1. As the error itself suggests, maybe the the project's virtual directory is not configured as an application in IIS.
    2. web.config files in sub-directories with illegal tags.
    3. Duplicate web.config files at the root or in a backup directory.

    Below are some links that describe these scenarios and may provide you with the solution to your problem:

    Please contact us again if you have any more questions.

    All the best,
    Randy Hodge
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Jerson
    Jerson avatar
    2 posts
    26 Nov 2012
    11 Jul 2013 in reply to Randy Hodge
    Link to this post
    I got a similar error message and want to share what worked for me.
    I had the project in VS2010 and then tried to open it in VS2012 , for some reason I didn't have the .sln file and I was trying to compile when using "open website". In my opinion the issue could be related to a framework version conflict.
    1- Install all the updates for Visual Studio 2012 and Sitefinity Thunder 
    2-Open (doubleclick) the "SitefinityWebApp.csproj" and let the VS do the some migration work, try to close (you will be asked to save the new .sln)
    2- Open Visual Studio "as administrator" (run as administrator) in the development server, open the new .sln file, rebuild and the error message goes away.
    I hope this help somebody.
3 posts, 0 answered