More in this section

Forums / Bugs & Issues / Form redirect not working

Form redirect not working

6 posts, 0 answered
  1. Chris
    Chris avatar
    7 posts
    Registered:
    19 Aug 2010
    04 Mar 2011
    Link to this post
    Hello,
    Within Sitefinity 4 forms you can choose to either display a message once form is submitted, or direct to a page within the site. I would like to use this method, but every time the form is submitted it just goes back to the form? I would like to redirect to another page. Any ideas? Thanks in advance.
  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    12 Sep 2017
    07 Mar 2011
    Link to this post
    Hello Chris,

    You should be able to use Redirect to a page Form setting that is available for each form.  This works properly in the SP1 release.

    Regards,
    Ivan Dimitrov
    the Telerik team
  3. Chris
    Chris avatar
    7 posts
    Registered:
    19 Aug 2010
    07 Mar 2011
    Link to this post
    Hi Ivan,
    The form once submitted just goes back to the form - but not completed.
  4. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    12 Sep 2017
    07 Mar 2011
    Link to this post
    Hello Chris,

    I am not able to replicate this issue with SP1. Can you try to replicate it on our sandbox? Is it possible to share a short video that shows your steps?

    Regards,
    Ivan Dimitrov
    the Telerik team
  5. Chris
    Chris avatar
    7 posts
    Registered:
    19 Aug 2010
    08 Mar 2011
    Link to this post
    Found the problem - the URL was almost exactly the same to the page I wanted the redirect...only a slightly small difference in the URL. So basically I had it redirecting back to the form without realizing it. Thanks for the help.
  6. Iain
    Iain avatar
    26 posts
    Registered:
    29 Dec 2010
    17 Oct 2011
    Link to this post
    Morning,

    I cant seem to find where the redirect option is in SF4.2 ?

    ! found it !

    Sorry
6 posts, 0 answered