More in this section

Forums / Bugs & Issues / Live Writer 2011 not working

Live Writer 2011 not working

15 posts, 0 answered
  1. Martin
    Martin avatar
    7 posts
    Registered:
    09 Aug 2010
    02 Aug 2011
    Link to this post
    Hello Guys,

    I have been struggeling with the blog functionality for a while now. Everything is working fine till I start using Live Writer 2011 for creating content.

    I setup the blog according to the documentation, after starting Live Writer, entering the url, username and password I get the following error: A problem occurred during detection of the weblog configuration. The underlying connection was closed: An unexpected error occurred on a receive.

    Monitoring the network traffic tells me that redirection to the atompub services is going well, authentication is requested and given by Live Writer, the blogs.svc is downloaded and then I see a redirect to blogs.svc/{GUID}. This page can't be displayed and the IIS logging is giving a 401 error.

    Enviroment:
    - Windows Server 2008 R2
    - IIS 7
    - SiteFinity version 4.1.1339.0
    - Live Writer 2011

    Thanks
  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    12 Sep 2017
    02 Aug 2011
    Link to this post
    Hello Martin,

    Here is a link to the documentation that shows how to set up live writer to work with Sitefinity.
    In Live Writer you need to set the page on which you have BlogPostView control that shows your posts. Make sure that AllowBlogging is set to true. Can you send some screenshots that shows BlogPostView control configuration ? Do you set ti to show specific blog, you have some filtering etc? Here is a short video that shows the setup and blog post publishing with Live Writer 2011 build 15.5.3508.1109.

    Greetings,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Martin
    Martin avatar
    7 posts
    Registered:
    09 Aug 2010
    03 Aug 2011
    Link to this post
    Hello Ivan,

    Yes allowblogging is selected, watched the video but did not see anything new or different. Attached some screenshots.

    Gert
  4. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    12 Sep 2017
    03 Aug 2011
    Link to this post
    Hello Martin,

    Is there more inform about the error in the server log? Error 500 does not provide much information and as you can see we could not replicate the issue locally.

    Regards,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  5. Martin
    Martin avatar
    7 posts
    Registered:
    09 Aug 2010
    04 Aug 2011
    Link to this post
    Hello Ivan,

    I did some testing and troubleshooting before I started the thread. What I learned is the following:

    Live Writer 2011 tries to connec to the page on an ip-adres instead of an host header, we changed the bindings to get further.

    In the webserver logging I see that there is an redirect to the atomservices/blogs.svc, followed by an succesfull authentication. It is ended with a redirect to the url below which is anonymous again and responded with a 401 error.

    /SiteFinity/Services/Atompub/Blogs.svc/{GUID}


  6. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    12 Sep 2017
    05 Aug 2011
    Link to this post
    Hello Martin,

    First the Live Writer makes a request without credentials to the blog and this first requests returns 401. Then there is second request where we pass the credentials. If the user is not authenticated with throw 401 again.
    Also the user you use should have permissions to create blog posts.


    Best wishes,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  7. Martin
    Martin avatar
    7 posts
    Registered:
    09 Aug 2010
    08 Aug 2011
    Link to this post
    Hello Ivan,

    That's exactly what i'm describing, the one time no authentication is send back is the time the redirect to the /{GUID} is done. Do you have an IIS logging of the process when it's working fine, just to compare?

    Do we have to create an support ticket to get this issue resolved?

    Regards,
    Martin
  8. Martin
    Martin avatar
    7 posts
    Registered:
    09 Aug 2010
    08 Aug 2011
    Link to this post
    By the way, the user is an administrator so permissions should not be a problem
  9. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    12 Sep 2017
    10 Aug 2011
    Link to this post
    Hi Martin,

    Could you attach your request logs from IIS so we can see them?Since we cannot replicate the issue it is quite hard to tell you what the problem is.
    You can also attach a log from fiddler or HttpWatch which could give us some more details and the log trace log from the atom pub service

    All the best,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  10. Martin
    Martin avatar
    7 posts
    Registered:
    09 Aug 2010
    11 Aug 2011
    Link to this post
    Hello Ivan,

    I have collected a lot of information:
    - Attached a screenshot from netmon, here you can see the get request and the 500 response and that the authorization is included in the request
    - IIS logfile
    - IIS tracing file of the 401 error

    The netmon is attached, the log and trace file not because I can only attach image files. Do you have an e-mail adrress where I can send them?

    Regards
  11. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    12 Sep 2017
    16 Aug 2011
    Link to this post
    Hello Martin,

    You can open a support request or bug report and attach the files there as a zip. We will review the log files and try to find what the problem is.

    Greetings,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  12. Martin
    Martin avatar
    7 posts
    Registered:
    09 Aug 2010
    16 Aug 2011
    Link to this post
    Hello Ivan,

    Support ticket is created with the files attached, number is  454428.

    Regards
  13. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    12 Sep 2017
    18 Aug 2011
    Link to this post
    Hi Martin,

    Ok we will check the logs and get back to you.

    Greetings,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  14. Stefan
    Stefan avatar
    5 posts
    Registered:
    21 Nov 2006
    15 Feb 2012
    Link to this post
    Hi,

    Im having the same trouble, did you find out anything when he posted the support ticket?

    Regards

    Stefan
  15. Stanislav Velikov
    Stanislav Velikov avatar
    1113 posts
    Registered:
    18 Sep 2017
    20 Feb 2012
    Link to this post
    Hi,

     The version used when encountering this problem was Sitefinity 4.1 SP1 (4.1.1395). In this version there was a regression in the blogging atompub service which was fixed later in Sitefinity 4.1 SP2.

    Kind regards,
    Stanislav Velikov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
15 posts, 0 answered