More in this section

Forums / Bugs & Issues / Pages : Anonymous Permission error

Pages : Anonymous Permission error

2 posts, 0 answered
  1. Anu
    Anu avatar
    72 posts
    Registered:
    17 Jun 2010
    27 May 2011
    Link to this post
    Hi,
    We are having a site developed in sitefinity 4.0.
    we want to put this site on staging server (Test server - for external users)
    we need to give password protection for this site.


    (IIS - Right click on website - select properties of the website go to Directory Security Tab and click on edit , then uncheck “Enable anonymous connection” and activate checkmark for “Basic authentication”)

    After removing anonymous connections, our site(front end) is working fine.
    But if i tried to login into sitefinity - pages then it is givng me error - "Security Settings for this services require Anonymous Authentication, but it is not enabled for the IIS application that host this service."

    I am not able to modify my pages on staging.
    Please help.Its very urgent.

    Thanks :)

  2. Victor Velev
    Victor Velev avatar
    1345 posts
    Registered:
    06 Jul 2015
    27 May 2011
    Link to this post
    Hello Anu,

    Sitefinity needs to have Anonymous authentication enabled to function properly. Otherwise you will ( like in your case ) encounter issues regarding the access to certain parts of the website.

    If you want somehow to restrict people from accessing your website, you can enable windows authentication. You can take a look at our documentation for more information about this possibility.

    There is also another option - you can restrict the access to only a number of IP addresses or by domain name. Please review this article.

    Greetings,
    Victor Velev
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
2 posts, 0 answered