More in this section

Forums / Bugs & Issues / Personalization not working as expected

Personalization not working as expected

9 posts, 0 answered
  1. Atit
    Atit avatar
    10 posts
    Registered:
    27 Feb 2015
    10 Aug
    Link to this post

    Hi,

    I am using Sitefinity 8.2 and I have created segment based on certain criteria (with OR operator). When I add condition for "Visited Page" and user has visited page, it shows correct content based on segment but other conditions (which we are planning to use) - Search keywords, Referral URL, Time Of Day, Location etc. are not working. When I check page through "View Page As", everything works fine, but when I visit actual page in my browser, I do not see content personalized.

    Also, is there a way I can identify what is current user's characteristic so if personalization is failing, I can determine why it is failing.

    I followed the steps as here - https://docs.sitefinity.com/overview-personalization

    Am I missing something? 

    Thanks
    Atit

  2. Nelssen
    Nelssen avatar
    0 posts
    Registered:
    14 Oct 2017
    5 days ago in reply to Atit
    Link to this post

    Hi Atit,

    Have you achieve any advancements? I'm Facing the same issue with Version 10.

    Cheers

  3. Atit
    Atit avatar
    10 posts
    Registered:
    27 Feb 2015
    5 days ago in reply to Nelssen
    Link to this post
    Hi, if you are trying to gret it to work based onn search terms, it won't work because search engines don’t pass search terms anymore.
  4. Nelssen
    Nelssen avatar
    0 posts
    Registered:
    14 Oct 2017
    4 days and 22 hours ago in reply to Atit
    Link to this post

    Thanks a lot Atit you saved me a lot of work. however that's a shocking news :((

    I tried again some characteristics of personalization and I managed to put them to work, they were:

    Visited page
    Roles,
    Profile fields (Tested with first name)
    referral  URL(from google)
    IP  for 0.0.0.0-0.0.0.0 worked but not for 0.0.0.0 on Localhost. maybe it works differently On live environments or if I deploy to IIS.

     

    Location, and Search (You Already Explainded) have not worked.

     

    Cheers

  5. Nelssen
    Nelssen avatar
    0 posts
    Registered:
    14 Oct 2017
    4 days and 22 hours ago in reply to Atit
    Link to this post
    Do you have references on search engines are not passing search terms?
  6. Nelssen
    Nelssen avatar
    0 posts
    Registered:
    14 Oct 2017
    4 days and 21 hours ago
    Link to this post

    Atit I believe that search engines are not related with search keywords. I think those keywords relate with the keywords you use on search widget. but I'm searching for a source to prove my words

  7. Nelssen
    Nelssen avatar
    0 posts
    Registered:
    14 Oct 2017
    4 days and 21 hours ago in reply to Atit
    Link to this post
    Confirmed that search keywords are the ones that lead you to the target site [HERE]
  8. Nelssen
    Nelssen avatar
    0 posts
    Registered:
    14 Oct 2017
    4 days and 21 hours ago
    Link to this post

    As far as I understood, you are right on that information. search keywords are now payed, and obtained in other way. [HERE]

     

     

     

  9. Atit
    Atit avatar
    10 posts
    Registered:
    27 Feb 2015
    4 days and 19 hours ago in reply to Nelssen
    Link to this post

    I opened a support ticket with telerik and they referred to me how search keyword based personalization works. They used browser adon and it worked, but in reality to maintain privacy google does not pass keywords. Search term based personalizatio deem useless with that fact.

     

     

9 posts, 0 answered