More in this section

Forums / Bugs & Issues / Removing Second Language

Removing Second Language

5 posts, 0 answered
  1. Jeff
    Jeff avatar
    9 posts
    Registered:
    29 Nov 2009
    30 Apr 2011
    Link to this post
    I have a site with pages in two languages, English (default) and French.  When I remove the second language using the Administration -> Settings -> Languages tool, suddenly some of the English pages show with French content.

    I thought perhaps that was because I have to delete all the French pages first before removing the language, so I restored the database, then deleted all the French pages.  (At this point the English pages were all fine).  Then I removed French as a language in Administration -> Settings -> Languages, and then instantly some (bt not all) of the English pages have French content.  Even when I edit them in Sitefinity they show the French content. 

    It seems that the French pages are not really deleted when I delete them with Sitefinity, and that after French is removed as a language option, Sitefinity is confused about which one to show as the default page.

    I am using the initial release of SF 4.0.  I can't upgrade to SF 4.1 yet.
  2. Stanislav Velikov
    Stanislav Velikov avatar
    1113 posts
    Registered:
    18 Sep 2017
    04 May 2011
    Link to this post
    Hello Jeff,

    Please accept our apologies for the inconvenience caused by this issue. This is a known problem and is expected to be fixed in the upcomming Q2.

    Greetings,
    Stanislav Velikov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Nabeel
    Nabeel avatar
    4 posts
    Registered:
    27 Sep 2011
    27 Jun 2012
    Link to this post

    Hi, 

    We are also facing the same issue, where we have different languages website e.g English, Czech, Russian, Chinese etc.

    When we removed the languages e.g. Russian and Chinese from Administration -> Settings -> Languages tool, the "Default" language e.g. Czech start showing page from Chinese and Russian. Meanwhile, the other language (English) website works fine and does not show different locale content. 

    The issue is only happening to Default Locale website. We are using Sitefinity 4.2.1733.0

    Let us know if the issue have been fixed. 

  4. Jochem Bökkers
    Jochem Bökkers avatar
    787 posts
    Registered:
    13 Aug 2007
    28 Jun 2012
    Link to this post
    Hey Nabeel,

    This is likely caused by the fact that the first version of the page is language invariant (meaning no culture gets assigned) when there's no other language present. Combined with in this case your wrongful czech page displays Chinese because that's the first version you created.

    Jochem.
  5. Nabeel
    Nabeel avatar
    4 posts
    Registered:
    27 Sep 2011
    28 Jun 2012
    Link to this post
    Thanks Jochem for your quick response.

    So how to we stop the other language content appear for the Default language site?
    As you can see from the following link, the pages from other site is appearing under the main section:

    http://easycaptures.com/fs/uploaded/580/7220300557.jpg 

    The above screenshot shows two version,
    - If Czech language is set as Default then the section start showing other languages overview pages.
    - If Czech language is NOT Default then it's shows only the correct Overview page.

    Make note that not all the pages shows this issue, it's happening for some pages, for other, it's working fine.
5 posts, 0 answered