More in this section

Forums / Bugs & Issues / Search Indexing Issue Sitefiity 4.2 SP1

Search Indexing Issue Sitefiity 4.2 SP1

2 posts, 0 answered
  1. waqar
    waqar avatar
    76 posts
    Registered:
    28 Mar 2011
    23 Oct 2011
    Link to this post
    Hi!

    I am getting an error " Object reference not set to an instance of an object"  when I perform search reindexing. My website has around 800 pages. I upgraded this site from SF 4.1 SP1 to SF 4.2 SP1.

    Can you please help me in this? What are the causes which  may produce this error in this scenario.

    Thanks
  2. Victor Velev
    Victor Velev avatar
    1345 posts
    Registered:
    06 Jul 2015
    25 Oct 2011
    Link to this post
    Hello Waqar,

    This is a general error which does not fully describe the problem. Can you tell us when did you start to get the message - immediately after the upgrade? Do you have custom controls on your website? Some of them might be breaking the index but indeed it is strange if it has worked before.

    What you need is to escape the crawler request. Please refer to the following code sample:

    if (this.Page.Items["IsInIndexMode"] == null)
     {
      // your logic here.
     }

    Also can you try and login to your website and replicate the issue - then attach the trace log and send it to me so I can have a closer look at the service exceptions.

    Kind regards,
    Victor Velev
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
2 posts, 0 answered