More in this section

Forums / Bugs & Issues / "Show in navigation" ignored for redirections

"Show in navigation" ignored for redirections

8 posts, 1 answered
  1. Thomas
    Thomas avatar
    223 posts
    Registered:
    19 Jan 2011
    22 Nov 2011
    Link to this post
    Hi,

    I thought this bug would be reported by now, but I looked around and couldn't find it.
    The "Show in navigation" option is ignored if the page is a redirection. Ie: it'll be shown in the navigation (menu) no matter what.

    To reproduce the problem:
    - Create a page
    - Uncheck the "Show in navigation" box
    - Check the "This page redirects to another page" box, and select a target page

    Result: the page is shown in the navigation.
    Expected result: the page is NOT shown in the navigation.

    Thanks.
  2. Thomas
    Thomas avatar
    223 posts
    Registered:
    19 Jan 2011
    22 Nov 2011
    Link to this post
    We tried to work around this bug by using page groups. This didn't work, though, because a page group (shown in navigation) that has its first child page set as not shown in navigation, makes it so the page group is not visible in the navigation.

    Not sure if this qualifies as a bug.
  3. Hristo Borisov
    Hristo Borisov avatar
    190 posts
    Registered:
    19 Jun 2017
    25 Nov 2011
    Link to this post
    Hello Thomas,

    I just tried to reproduce your scenario with our Sitefinity 4.3 release but with no success. Would you elaborate more on the version you use, so that we can isolate the problem internally and get back to you with a resolution to the problem?

    Thank you for contacting us, and I look forward to hearing from you.

    Regards,
    Hristo Borisov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  4. Thomas
    Thomas avatar
    223 posts
    Registered:
    19 Jan 2011
    25 Nov 2011
    Link to this post
    Hi Hristo,

    This is with Sitefinity 4.3.

    I'm wondering, are your online sandboxes on Sitefinity 4.3?
    If they are, I could create a new sandbox, reproduce the problem there, then you could check it out. Would that work for you?
  5. Sonya
    Sonya avatar
    205 posts
    Registered:
    09 Dec 2016
    30 Nov 2011
    Link to this post
    Hello Thomas,

    We've managed to reproduce the problem locally and, the problem appears only, when the page redirects to a Sitefinity page. The bug is not valid if you redirect to an external page. The issue is logged in our system and forwarded for fixing.  You can monitor the status of the bugs in our issue tracking system PITS. The issue ID is 8683.

    I updated your Telerik points.



    Greetings,
    Sonya
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
    Answered
  6. Thomas
    Thomas avatar
    223 posts
    Registered:
    19 Jan 2011
    30 Nov 2011
    Link to this post
    Hi Sonya,

    Thanks for the info.
    So I guess I could work around the issue for now by adding the full URL instead. I'll try that later on.
  7. Chris
    Chris avatar
    49 posts
    Registered:
    20 Jul 2010
    29 Feb 2012
    Link to this post
    I am having this problem now but I have noticed that if the page I am redirecting to is set to NOT show in the navigation while the redirecting page IS set to show in the navigation, the redirecting page will also NOT show in the navigation. This is only an issue for me because my blog page is acting extremely weird in my site's navigation. I'll make a separate post for that soon.
  8. Markus
    Markus avatar
    2763 posts
    Registered:
    25 Nov 2005
    01 Mar 2012
    Link to this post
    Dear Chris

    Unfortunaltely this is by design. See my sugestion here http://www.sitefinity.com/devnet/forums/sitefinity-4-x/suggestions/redirect-pages-show-in-navigation-only-when.aspx

    You can vote for it. Here is the link to PITS.

    To me it does not make sense that internal pages are handled differently then external. Maybe you want the impressum or disclaimer not to be shown in navigation but want to link to it from many pages.

    Work around would be treating the internal pages as external pages and access them with http://www.watever.ch

    Markus
8 posts, 1 answered