More in this section

Forums / Bugs & Issues / SiteMapDataSource and StartingNodeOffset=1 broke in 4.1sp1

SiteMapDataSource and StartingNodeOffset=1 broke in 4.1sp1

3 posts, 0 answered
  1. Michael
    Michael avatar
    59 posts
    Registered:
    02 Nov 2010
    06 Jun 2011
    Link to this post
    Worked great before as usual but now yet another thing you broke.  Any plans to fix this soon?

    Setting it to 0 works fine but shows all my pages, i only want to show pages under a specific group of pages for a sidebar sub nav i wrote.

    Or can you provide some sort of working work around that won't break once its fixed
  2. Boyan Barnev
    Boyan Barnev avatar
    1429 posts
    Registered:
    30 Oct 2017
    07 Jun 2011
    Link to this post
    Hello Michael,

    Can you please let us know of the exact use case scenario where you have this functionality not working? Please take a look at the attached video showing a simple setup for SiteMapDataSource with StartingNodeOffset set to 1 and RadPanelBar and how it functions using our latest version. If you need any additional information, please let us know.

    Best wishes,
    Boyan Barnev
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Michael
    Michael avatar
    59 posts
    Registered:
    02 Nov 2010
    07 Jun 2011
    Link to this post
    i ended up fixing it on my own.  Had to use the built in navigation control, set it to custom link it to my custom treeview control, then override the onprerender to set the startingnodeoffset correctly.

       protected override void OnPreRender(EventArgs e)
            {
                base.OnPreRender(e);
                ((SiteMapDataSource)RadTreeviewTree.DataSource).StartingNodeOffset = 1;
                ((SiteMapDataSource)RadTreeviewTree.DataSource).StartFromCurrentNode = false;
     
                RadTreeviewTree.DataBind();
    }
3 posts, 0 answered