More in this section

Forums / Bugs & Issues / Unable to change or view templates...

Unable to change or view templates...

11 posts, 0 answered
  1. Chris Bryant
    Chris Bryant avatar
    33 posts
    Registered:
    07 Jul 2009
    27 Apr 2011
    Link to this post
    Whenever I try to select a page template or view page templates, I received the following error:

    No row for Telerik.Sitefinity.Pages.Model.PageData ('sf_page_data') GenericOID@76844400 PageData content_id=d8440da3-8cc0-497b-a4e8-224a36fa37d8

    I've looked in the 'sf_page_data' table, and this row does not exist.  Is there someplace else that this is being referenced?

    Please help!
    -Chris B.
  2. Pepi
    Pepi avatar
    981 posts
    Registered:
    31 Jan 2017
    29 Apr 2011
    Link to this post
    Hi Chris ,

    Please, check if the following query will return any results:

    select *
    from sf_page_node
    where content_id is not null and content_id not in (select content_id from sf_page_data)

    If the above query returns records, run the following script (we would strongly recommend you backup your database before executing the script):

    update sf_page_node
    set content_id = null, node_type = 1
    where content_id is not null and content_id not in (select content_id from sf_page_data)

    Let us know if this helps.

    All the best,
    Pepi
    the Telerik team

  3. Rob
    Rob avatar
    6 posts
    Registered:
    28 Oct 2010
    13 May 2011
    Link to this post
    Hi,

    When I want to edit my page templates I get an almost similar error (just different id's):
    No row for Telerik.Sitefinity.Pages.Model.PageData ('sf_page_data') GenericOID@4745cca3 PageData content_id=77a688c8-efe3-4409-9322-df55bef19962

    The error appears in a messagebox. When clicking OK, the messagebox reappears. I have to kill the browser process to close it.

    I have tried the query mentioned by Pepi, but there were no records returned in the first query. Can you inform us how to recover from this and most all how to prevent this (until there is a fix)? I was doing nothing to special, just editing a page with a navigation control added to it on the template.


    Kind regards,

    Rob Houweling
  4. Pepi
    Pepi avatar
    981 posts
    Registered:
    31 Jan 2017
    17 May 2011
    Link to this post
    Hello Rob,

    Could you open a new support ticket and send us the following files to investigate the issue locally:
    1. Database
    2. Configuration files located in ~/App_Data/Sitefinity/Configuration folder
    3. web.config file
    4. Master pages (if you use any)

      Thanks for your cooperation in advance.

      Regards,
      Pepi
      the Telerik team
      Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
    1. David
      David avatar
      1 posts
      Registered:
      31 May 2011
      14 Jun 2011
      Link to this post
      I have the same exact error.

      I tried your Query Pepi --> no Results.

      Searched the database for this id and i had no luck.

      Greetings Dave
    2. Pepi
      Pepi avatar
      981 posts
      Registered:
      31 Jan 2017
      16 Jun 2011
      Link to this post
      Hello David,

      Could you try to reset the application and then check if you can reproduce the exception? Also, it will be very helpful if you send us your error log. Currently, we are investigation a problem with second level cache
      and we suppose the reported issue could be related to it.

      Kind regards,
      Pepi
      the Telerik team
      Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
    3. Jon
      Jon avatar
      2 posts
      Registered:
      17 Jun 2011
      20 Jun 2011
      Link to this post
      Has this been resolved? I'm getting the same error? I can't edit any template files and am forced to close the browser due to infinite alert dialogs.
    4. Petya
      Petya avatar
      123 posts
      Registered:
      30 May 2017
      21 Jun 2011
      Link to this post
      Hello Jon,

      Can you tell me what version of Sitefinity are you using? Have you made upgrades from previous versions? Can you provide us some exact steps to follow or access to your database? Thanks in advance!

      Kind regards,
      Petya
      the Telerik team
      Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
    5. jkregala
      jkregala avatar
      159 posts
      Registered:
      22 Sep 2009
      30 Jun 2011
      Link to this post
      Please advise others to try an IIS reset. It worked for me.
    6. Scott
      Scott avatar
      3 posts
      Registered:
      13 Mar 2012
      05 Apr 2012
      Link to this post
      I just got this error in 4.4.  It is almost a year old.  Is it going to be fixed?  If the IIS reset does not wok for me (I am using the internal server) i have lost lost 6 hours of work.
    7. Scott
      Scott avatar
      3 posts
      Registered:
      13 Mar 2012
      05 Apr 2012
      Link to this post
      I just got this error in 4.4.  The bug is almost a year old.  Is it going to be fixed?  If the IIS reset does not wok for me (I am using the internal server) i have lost lost 6 hours of work.
    11 posts, 0 answered