More in this section

Forums / Developing with Sitefinity / Breadcrumb + Blog

Breadcrumb + Blog

4 posts, 0 answered
  1. Steve
    Steve avatar
    3037 posts
    Registered:
    03 Dec 2008
    11 Jun 2012
    Link to this post
    The breadcrumb doesn't seem to be affected by filtering...by that I mean if I have a breadcrumb on my master and a page at:
    ~/Blog

    It renders
    <a href="home">Home</a> / <a href="javascript: void(0)">Blog</a>

    So then if I drill into a blog post, I'd assume it'd render this:
    <a href="home">Home</a> / <a href="/blog">Blog</a> /  <a href="javascript: void(0">My blog post</a>

    You want to use the breadcrumb to navigate back to the blog page, but it's impossible...

    Is this an option on the B/C somewhere, or just an oversight?
  2. Rafael
    Rafael avatar
    7 posts
    Registered:
    01 Nov 2012
    03 Dec 2012
    Link to this post
    Hi Steve,

    Have you found a solution? I'm having the same problem and I need to to that.
  3. Steve
    Steve avatar
    3037 posts
    Registered:
    03 Dec 2008
    03 Dec 2012 in reply to Rafael
    Link to this post
    5.2 SP1 should have allowed "detail items" to showup in the breadcrumb...there's a new property on it called "AllowVirtualNodes".  Set it to True and see what happens?

    I haven't updated to SP1 yet myself to see if it's fixed for blogs (I know it is for module builder detail items though)
  4. Rafael
    Rafael avatar
    7 posts
    Registered:
    01 Nov 2012
    04 Dec 2012
    Link to this post
    Hi Steve,

    I've installed the Sitefinity 5.2 SP1 and I've changed this property as you wrote me and now the breadcrumb is working as I want. 

    Thanks
4 posts, 0 answered