More in this section

Forums / Developing with Sitefinity / Could not load file or assembly 'Telerik.Sitefinity.Mvc, Version=1.3.300.1

Could not load file or assembly 'Telerik.Sitefinity.Mvc, Version=1.3.300.1

1 posts, 0 answered
  1. Noel
    Noel avatar
    2 posts
    11 Dec 2015
    09 Feb 2016
    Link to this post


    I've started recceiving this error during initialization when trying to load my site from my local machine. It was launching fine, and then this started happening. I'm don't know what I did to cause this. It is not happening with the same project on other machines. I tried upgrading to the latest Feather, 1.4.430, which also upgrades Telerik.Sitefinity.Mvc, but I get the same error. 1.4.430 is the version of Telerik.Sitefinity.Mvc referenced in my project. Here is the full text of the error:

    Could not load file or assembly 'Telerik.Sitefinity.Mvc, Version=1.3.300.1, Culture=neutral, PublicKeyToken=b28c218413bdf563' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040) 

    Thank you


    I got around this by adding the following assembly binding tag to the existing list of assembly bindings in the web.config:

            <assemblyIdentity name="Telerik.Sitefinity.Mvc" publicKeyToken="b28c218413bdf563"/>
            <bindingRedirect oldVersion="" newVersion="1.4.430.0"/>

1 posts, 0 answered