More in this section

Forums / Developing with Sitefinity / Custom module installation problem

Custom module installation problem

2 posts, 0 answered
  1. Kenny South
    Kenny South avatar
    16 posts
    Registered:
    11 Jan 2010
    18 Oct 2012
    Link to this post
    Hi,

    I'm trying to install a custom module in sitefinity 5.1. The implementation of my module is based on the products module i found on the 5.1 SDK.

    After referencing my assembly in the sitefinity application and restarting the application pool, this error came out:

    [ArgumentException: File "/_appstart.cshtml" does not exist.
    Nom du paramètre : virtualPath]
       Telerik.Sitefinity.Abstractions.VirtualPath.VirtualPathManager.GetCacheDependency(String virtualPath, IEnumerable virtualPathDependencies, DateTime utcStart) +404
       Telerik.Sitefinity.Abstractions.VirtualPath.SitefinityVirtualPathProvider.GetCacheDependency(String virtualPath, IEnumerable virtualPathDependencies, DateTime utcStart) +257
       System.Web.WebPages.ApplicationStartPage.MonitorFile(String virtualPath) +98
       System.Web.WebPages.ApplicationStartPage.<ExecuteStartPage>b__4(String vpath) +5
       System.Web.WebPages.ApplicationStartPage.ExecuteStartPageInternal(HttpApplication application, Action`1 monitorFile, Func`2 fileExists, Func`2 createInstance, IEnumerable`1 supportedExtensions) +101
       System.Web.WebPages.ApplicationStartPage.ExecuteStartPage(HttpApplication application, Action`1 monitorFile, Func`2 fileExists, Func`2 createInstance, IEnumerable`1 supportedExtensions) +42
     
    [HttpException (0x80004005): Une exception de type 'System.Web.HttpException' a été levée.]
       System.Web.WebPages.ApplicationStartPage.ExecuteStartPage(HttpApplication application, Action`1 monitorFile, Func`2 fileExists, Func`2 createInstance, IEnumerable`1 supportedExtensions) +88
       System.Web.WebPages.ApplicationStartPage.ExecuteStartPage(HttpApplication application) +265
       System.Web.WebPages.WebPageHttpModule.StartApplication(HttpApplication application, Action`1 executeStartPage, EventHandler applicationStart) +84
       System.Web.WebPages.WebPageHttpModule.StartApplication(HttpApplication application) +53
       System.Web.WebPages.WebPageHttpModule.Init(HttpApplication application) +179
       System.Web.HttpApplication.RegisterEventSubscriptionsWithIIS(IntPtr appContext, HttpContext context, MethodInfo[] handlers) +517
       System.Web.HttpApplication.InitSpecial(HttpApplicationState state, MethodInfo[] handlers, IntPtr appContext, HttpContext context) +194
       System.Web.HttpApplicationFactory.GetSpecialApplicationInstance(IntPtr appContext, HttpContext context) +339
       System.Web.Hosting.PipelineRuntime.InitializeApplication(IntPtr appContext) +253
     
    [HttpException (0x80004005): Une exception de type 'System.Web.HttpException' a été levée.]
       System.Web.HttpRuntime.FirstRequestInit(HttpContext context) +9088636
       System.Web.HttpRuntime.EnsureFirstRequestInit(HttpContext context) +97
       System.Web.HttpRuntime.ProcessRequestNotificationPrivate(IIS7WorkerRequest wr, HttpContext context) +256

    I put some logging mechanism for debugging purpose in my module class, but the problem take place before my code is executed.

    Any help will be much appreciated!
  2. Kenny South
    Kenny South avatar
    16 posts
    Registered:
    11 Jan 2010
    18 Oct 2012 in reply to Kenny South
    Link to this post
    the version of sitefinity is 5.0 for the webapplication. I suppose i need to upgrade to 5.1 before installing the custom module. i'll look into it
2 posts, 0 answered