More in this section

Forums / Developing with Sitefinity / Problem after upgrade to SF 5.0 with custom module compiling

Problem after upgrade to SF 5.0 with custom module compiling

6 posts, 0 answered
  1. Daniel Plomp
    Daniel Plomp avatar
    952 posts
    Registered:
    18 Feb 2004
    06 Mar 2012
    Link to this post
    Hi guys,

    Maybe I'm forgetting something, but after upgrading to SF 5.0 I also tried to upgrade my custom modules. I pointed to the new assemblies and hit Build. I'm getting the error:

    Error 38 The given key was not present in the dictionary.

    No matter what I try, it won't build.
    I know that it still uses the OpenAccess enhancer that comes with the 4.4 SDK. Does it mean I have to wait for the 5.0 SDK? I tried to use the enhancer of a separate OpenAccess installation (latest version) but that doesn't work.

    Anyone else who had this problem?

    Daniel
  2. Daniel Plomp
    Daniel Plomp avatar
    112 posts
    Registered:
    14 Jun 2012
    06 Mar 2012
    Link to this post
    Well, it definitely is some OpenAccess related as my Output window shows:
    OpenAccess Enhancer error 0: The given key was not present in the dictionary.

    Regards,
    Daniel
  3. Victor Velev
    Victor Velev avatar
    1345 posts
    Registered:
    06 Jul 2015
    06 Mar 2012
    Link to this post
    Hi Daniel,

    As you may have noticed the SDK for 5.0 is still not released ( it will be pretty soon ), so what I can suggest you is to wait for it and then upgrade all your custom modules and reference to the new assemblies ( and the enhancer as well ).

    Regards,
    Victor Velev
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  4. Saeed
    Saeed avatar
    14 posts
    Registered:
    21 Jun 2011
    07 Jan 2013 in reply to Daniel Plomp
    Link to this post

    Hi Daniel,

    I'm going to migrate a Sitefinity 4.2 project to 5.3.

    So I migrated it to 4.3 and then 5.0 but as soon as I updated it to V5.0 I got same error!

    Could you advice how you have handled it?

    Thanks,
    Saeed!


  5. Victor Velev
    Victor Velev avatar
    1345 posts
    Registered:
    06 Jul 2015
    09 Jan 2013
    Link to this post
    Hi Saeed,

    Can you please elaborate a bit more on the process of upgrading to 5.0? Do you have any custom modules in your project? If you have such, did you enhance the modules after upgrade to 5.0?

    Regards,
    Victor Velev
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  6. Daniel Plomp
    Daniel Plomp avatar
    952 posts
    Registered:
    18 Feb 2004
    09 Jan 2013 in reply to Saeed
    Link to this post
    Hi Saeed,

    In the end all problems were caused by wrong references. The thing is that this is hard to find out, so I spend much time deleting and re-adding references to the right projects. I use the Sitefinity website as main source for all references that I make from other projects.

    I also had problems with some marketplace controls that had their own libraries included that were build agains older Sitefinity versions, so that could maybe also be a problem?

    Regards,
    Daniel
6 posts, 0 answered