More in this section

Forums / Developing with Sitefinity / Selectors - how to make them work !?!, examples dont help

Selectors - how to make them work !?!, examples dont help

3 posts, 0 answered
  1. Rory
    Rory avatar
    44 posts
    Registered:
    22 Mar 2012
    23 Apr 2012
    Link to this post
    Hello. i have spent that last few days trying to figure out how to create a basic user selector and it is proving to be ridiculously frustrating. i am using latest sitefinity (5.x).

    i have gone though this example: 
    http://www.sitefinity.com/documentation/documentationarticles/developers-guide/how-to/how-to-create-a-simple-image-selector 
    but cannot even get this to work.  when i try it, instead of a list of my images all i get is a label with "{{Title}}", as shown in the image.

    i need to setup a control similar to when adding users to a role where i can select from a list of users.  

    any suggestions on how to get this sitefinity example?  Are there more steps that they just didn't bother to explain about on the example?
  2. Ivan Eftimov
    Ivan Eftimov avatar
    23 posts
    Registered:
    08 Feb 2017
    24 Apr 2012
    Link to this post
    Hello Rory,

    Thank you for contacting us about your issue. The post that you were folowing was updated. Here you can see the updated post and folow the instructions there (pay attention to the Installation Instructions at the bottom). Also I recommend you to folow this video which visually explains all the steps (I think it will help you solve your problem faster).

    Still, if you did all the steps in the post you were following, the only thing you should do is to slightly tweak your simpleimageselector:
        1. Go to your page and click "Edit" on the simpleimageselector;
        2. Go to "List Settings" and under the "List template" field/(dropdown menu) click "Edit selected template";
        3. Paste the folowing markup under the other declarations of the same type:      
    <%@ Register TagPrefix="samples" Namespace="Telerik.Sitefinity.Samples" Assembly="SitefinityWebApp" %>
         
     4. Then paste the following code, depending on where you want to show the thumbnails:  
    <samples:SimpleImageField runat="server" DisplayMode="Read" Value='<%# Eval("Thumbnail")%>' />
    Save your setting and you are ready to go :).

    This is also clearly explained and shown in the video. Try to follow it and do all the steps, and the solution will work. If you still have troubles with it, do not hesitate to contact me again.


    All the best,
    Ivan
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Rory
    Rory avatar
    44 posts
    Registered:
    22 Mar 2012
    24 Apr 2012
    Link to this post
    Hi Ivan.  thanks for the reply.  i had gone through those examples as well.   i did get this example working so am making progress now. http://www.sitefinity.com/blogs/radoslavgeorgiev/posts/12-02-27/creating_one_to_many_relationships_in_dynamic_modules.aspx 


    still not sure why the simple image selector wont work, i will go back to it in a bit and try what you suggested.  thanks again.
3 posts, 0 answered