More in this section
Forums / Developing with Sitefinity / Webtolead form with user control not working

Webtolead form with user control not working

The forums are in read-only mode. In case that you want to directly contact the Progress Sitefinity team use the support center. In our Google Plus group you can find more than one thousand Sitefinity developers discussing different topics. For the Stack Overflow threads don’t forget to use the “Sitefinity” tag.
2 posts, 0 answered
  1. Surya CD
    Surya CD avatar
    57 posts
    06 Apr 2010
    23 Jun 2012
    Link to this post
    I have created a user control to be used as webtolead form. The site is done in Sitefinity.
    The usercontrol is given in a masterpage. The hidden fields  oid, sfga are given in the ascx file.
    In the codebehind, I am submitting the form elements values using Response.Redirect method.
    But though it seems to submit data to SalesForce and is redirecting to a thankyou page, I am not getting the email. That means there is some issue. Here is my code for submit button click
    Response.Redirect("" + this.txtFname.Value +
                 "&last_name=" + this.txtLName.Value + "&company=" + this.txtCompany.Value +
                  "&state=" + this.txtState.Value + "&phone=" + this.txtPhone.Value +
                 "&email=" + this.txtEmail.Value + "&00N80000002PziG=" + this.ddlPrimaryInt.SelectedItem.Value +
                 "&description=" + this.txtComments.Value + "&Campaign_ID=" + this.Campaign_ID.Value +
                 "&retURL=" + "http://" + urlHost + "/lp/thankyou");

    Can anyone please help me with this.
    First of all, my doubt is can this be done using a user control. In the salesforce site, the example is see is done using html.

  2. Tim
    Tim avatar
    258 posts
    22 Jun 2011
    25 Jun 2012
    Link to this post
    It looks like you're doing a "GET", should it be a "POST"?

    I found a web to lead class that may be of use.
2 posts, 0 answered