More in this section
Forums / Developing with Sitefinity / You are not allowed to modify this page

You are not allowed to modify this page

The forums are in read-only mode. In case that you want to directly contact the Progress Sitefinity team use the support center. In our Google Plus group you can find more than one thousand Sitefinity developers discussing different topics. For the Stack Overflow threads don’t forget to use the “Sitefinity” tag.
3 posts, 0 answered
  1. Tim
    Tim avatar
    7 posts
    17 Oct 2012
    22 May 2013
    Link to this post
    Currently working on Sitefinity project. I have a replicated DB from live in my desktop running in  my source code. I tried to edit a page in hit Publish but it doesn't allow me to edit it.

    Saying, "You are not allowed to modify this page: Signature Events"

    I have check my user account and find out it's an administrator account.
    So the question is how is this happen, can someone help me please?

    I just notice that you can only modify the pages or content directly from live site, but when i backup and restored the DB in my desktop then tried to edit a page or content it wont allow me. Please help!

  2. Pavel Benov
    Pavel Benov avatar
    341 posts
    14 Mar 2016
    27 May 2013
    Link to this post
    Hi Tim,

    Make sure that your application pool's identity is owner of the DB and scheme - see image for reference. Additionally provide it read/write permissions for the project's folder.

    Pavel Benov
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Cadre Admin
    Cadre Admin avatar
    6 posts
    30 Jan 2014
    11 Dec 2015 in reply to Pavel Benov
    Link to this post
    Any additional thoughts on this? I have the exact same scenario when I just moved my SF 4.1 site to a new server. I have made my AppPool user dbo and given that user full access to the site files, but I am also still getting this error. Nothing in the error logs either.
3 posts, 0 answered