More in this section

Forums / Developing with Sitefinity / Access Images from library via silverlight

Access Images from library via silverlight

6 posts, 0 answered
  1. Steven Reid
    Steven Reid avatar
    16 posts
    Registered:
    27 Jan 2010
    18 Feb 2010
    Link to this post
    Good afternoon,

    I am coming to the end of my prototyping a Sitefintiy site and have hit a wall.

    I have a Silverlight control using RADCoverFlow. I am unable to retrieve files from the image library using links
    like:
    http://localhost/MySite/Libraries/Site_Images/Test_1.sflb.ashx
    ,which work on a normal page

    Any Ideas?

    Cheers

    Steven
  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    12 Sep 2017
    18 Feb 2010
    Link to this post
    Hi Steven Reid,

    You can use reals extensions for files uploaded to Images and Documents. For more detailed information, please take a look at How to use the real extensions for the items in the Images and Documents module

    Best wishes,
    Ivan Dimitrov
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  3. Steven Reid
    Steven Reid avatar
    16 posts
    Registered:
    27 Jan 2010
    18 Feb 2010
    Link to this post
    Ivan,

    Thanks for the help. All my images are now returning  urls like

    http://localhost/Test/Libraries/Products/Test.jpg

    But all the links are broken. I have uploaded all the images to a new products Image library and updated the GUIDs for each item. However , I am unable to retrieve any images at all. All the links are broken.

    Have I missed a step? or misunderstood something?

    Cheers

    Steven
  4. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    12 Sep 2017
    18 Feb 2010
    Link to this post
    Hello Steven Reid,

    If you upload a new image you should not have a problem  with the url. Actually this solution uses handler that gets the type from the web.config and add it to the image name.

    All the best,
    Ivan Dimitrov
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  5. Steven Reid
    Steven Reid avatar
    16 posts
    Registered:
    27 Jan 2010
    18 Feb 2010
    Link to this post
    Ivan,
    I am getting some strange output. From the admin package I can see the thumbnail for the image, but when I click view original I get a 404.

    This is on new  uploaded images. the old images are still working fine.

    Cheers

    Steven
  6. Steven Reid
    Steven Reid avatar
    16 posts
    Registered:
    27 Jan 2010
    19 Feb 2010
    Link to this post
    I have fixed my problem thanks to this post

    http://www.sitefinity.com/support/forums/sitefinity-3-x/deployment/questions-on-quot-how-to-use-real-extensions-quot-kb-article.aspx

    I was missing the last step and not  adding the handler mappings correctly.

    Thanks for the Help

    Steven
Register for webinar
6 posts, 0 answered