More in this section

Forums / Developing with Sitefinity / Cant Load Website

Cant Load Website

6 posts, 0 answered
  1. Daniel
    Daniel avatar
    62 posts
    Registered:
    20 Apr 2009
    15 Mar 2010
    Link to this post
    Hi Support,

    I have a strange issue where the website will not load firefox states the page is in a redirect loop, however this happens on the homepage the sitefinity backend pages so it cant be an issue with any master pages or code.

    However it was looping to an error page but then the error page was trying to reload itself several times not sure why as again this page was created in sitefinity.

    I have restarted IIS and even the box, I have also removed from the web.config file the line that redirects the page to the security error page but firefox still says it is in a loop. I have also tried clearing my cache and it is not just My machine it is happening on.

    When firefox errors there is nothing in the event log but occasionally I do get a thread was being aborted error which the contents of the error log ae below:

    Event code: 3005
    Event message: An unhandled exception has occurred.
    Event time: 15/03/2010 12:43:12
    Event time (UTC): 15/03/2010 12:43:12
    Event ID: 69b18d7eefa840edb7ac36b694a56838
    Event sequence: 9
    Event occurrence: 1
    Event detail code: 0
      
    Application information:
        Application domain: /LM/W3SVC/1/Root/Ebusiness-2-129131305260781250
        Trust level: Full
        Application Virtual Path: /Ebusiness
        Application Path: C:\Program Files\telerik\Sitefinity3.5 Community\WebSites\Ebusiness\
        Machine name: WIN2003DEV3
      
    Process information:
        Process ID: 3828
        Process name: w3wp.exe
        Account name: WIN2003DEV3\ebusiness
      
    Exception information:
        Exception type: ThreadAbortException
        Exception message: Thread was being aborted.
      
    Request information:
        Request path: /EBusiness/alpsphome.aspx
        User host address: 192.168.20.19
        User: 
        Is authenticated: False
        Authentication Type: 
        Thread account name: WIN2003DEV3\ebusiness
      
    Thread information:
        Thread ID: 6
        Thread account name: WIN2003DEV3\ebusiness
        Is impersonating: False
        Stack trace:    at Telerik.ModuleManager.LoadModules(Boolean reload)
       at Telerik.Cms.Web.CmsHttpModule.Init(HttpApplication context)
       at System.Web.HttpApplication.InitModulesCommon()
       at System.Web.HttpApplication.InitModules()
       at System.Web.HttpApplication.InitInternal(HttpContext context, HttpApplicationState state, MethodInfo[] handlers)
       at System.Web.HttpApplicationFactory.GetNormalApplicationInstance(HttpContext context)
       at System.Web.HttpApplicationFactory.GetApplicationInstance(HttpContext context)
       at System.Web.HttpRuntime.ProcessRequestInternal(HttpWorkerRequest wr)
      
      
    Custom event details:
     
    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.


    Thanks alot in advance

    Dan
  2. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    Registered:
    01 Feb 2016
    15 Mar 2010
    Link to this post
    Hi Daniel,

    Thank you for using our services.

    Could you please check if you have some Response.Redirect() calls in the page you are trying to access (http://win2003dev3/EBusiness/alpsphome.aspx)?  If yes could you please see whether calling the Resonse.Redirect(Url,false) will do the trick. If you set a second parameter it indicates whether to continue to process the current page. Setting it to false should resolve the problem. Also please not that if you have put Response.Redirect in a try catch you will get this error thrown, so the false parameter will also work there.

    Greetings,
    Radoslav Georgiev
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  3. Daniel
    Daniel avatar
    62 posts
    Registered:
    20 Apr 2009
    15 Mar 2010
    Link to this post
    Hi Radoslav,

    I have no response.redirects in any of the files at the moment. Like I said it doesnt just happen for that page it also happens to the sitefinity pages as well!

    I am at a loss!

    Thanks again

    Dan
  4. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    Registered:
    01 Feb 2016
    15 Mar 2010
    Link to this post
    Hello Daniel,

    Thank you for getting back me.

    What have been the most recent changes on your project which might have made the project throw this exception? I do not think that this message just started appearing without any changes happening to the website. This include code changes, changes in IIS configuration, etc. The easiest way to determine if the issue is due to IIS setup is to open the project in Visual Studio and run it through the built-in WebDevelopment Server.

    Any additional information will help us troubleshoot the issue.

    Sincerely yours,
    Radoslav Georgiev
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  5. Daniel
    Daniel avatar
    62 posts
    Registered:
    20 Apr 2009
    15 Mar 2010
    Link to this post
    Hi Radoslav,

    I thought as well - So I started rolling back all the changes we made this morning only trouble is 90% of it was general content based stuff.


    Any way it has gone back to how it was this morning and the problem still persists I am sorry I cant give you anymore details I have not got the slightest idea what could be causing it and where that cause could be?

    The securityerror.aspx page only has a label on the user control that gets populated with the querystring contents

    In this case the querystring is stating access is not allowed to the resource but that is on every page.  Then the page hasnt even finished loading but it then redirects but again there is no redirects on this page?

    Sorry I havent got any more info than that!

    Dan

    Additional Note I have noticed that in the sitefinity database there are two security.aspx pages - can i delete one of them and recreate it later as this may have something to do with it???? If so what other tables will I need to delete stuff from?
  6. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    Registered:
    01 Feb 2016
    16 Mar 2010
    Link to this post
    Hello Daniel,

    Thank you for getting back to me.

    Well this issue is really strange. Could you try not forwarding to the security error page to see what the result would be? Tables containing page data in Sitefinity db are sf_PageBase, sf_PageContentBase, sf_CmsPageContent, sf_CmsPageProps.


    Kind regards,
    Radoslav Georgiev
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
Register for webinar
6 posts, 0 answered