More in this section

Forums / Developing with Sitefinity / Could not load file or assembly 'Sitefinity_Pluggable_Module2' or one of its dependencies. The system cannot find the file specified.

Could not load file or assembly 'Sitefinity_Pluggable_Module2' or one of its dependencies. The system cannot find the file specified.

3 posts, 0 answered
  1. Zahid Ali
    Zahid Ali avatar
    47 posts
    Registered:
    16 Nov 2009
    20 Nov 2009
    Link to this post
    Hi,

    I'm trying to work with bare bones module with the help of instructions.txt.

    What could be wrong and how do I get rid of this error?

    I downloaded the files from here: http://www.sitefinity.com/help/developer-manual/adding-new-modules-pluggable-bare-bones.html

    I'm working wint VIsual Studio 2008, Framework 3.5.

    Ps. When i try to add reference - i get this error: Telerik.Cms.Web.UI.dll  or one of its dependencies, requires a later version of the .NET work.

    please help.

    thanks.
  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    12 Sep 2017
    20 Nov 2009
    Link to this post
    Hi Zahid Ali,

    1. You should add project reference to Telerik.Samples.Products code library.
    2. You should compiled your project to generate Telerik.Samples.Products.dll in your bin.
    3. You should add all required assemble reference for Telerik.Samples.Products project

    Kind regards,
    Ivan Dimitrov
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  3. Zahid Ali
    Zahid Ali avatar
    47 posts
    Registered:
    16 Nov 2009
    23 Nov 2009
    Link to this post
    hi Ivan,

    Where in the entire post did you read anything about telerik products sample?

    please read the message carefully - i'm having to struggle to explain to you. I feel you don't read the post properly before replying.

    I've even sent you the link to the page I've downloaded the pluggable module files from.

    my issue is: the files i downloaded from the link below don't seem to work. is it because when I add the reference 'telerik.cms.web.uk' - i get a message that the dependencies require newer .NET framework.

    please reply at your earliest convenience.

    thanks.
Register for webinar
3 posts, 0 answered