More in this section

Forums / Developing with Sitefinity / Default page for domain

Default page for domain

6 posts, 1 answered
  1. Chris Avenick
    Chris Avenick avatar
    4 posts
    Registered:
    01 Dec 2009
    09 Dec 2009
    Link to this post
    Hello I am new to SiteInfinity so any help will be appreciated.  I understand the concept of setting a page as the default document so when you go to www.domain.com it redirects to that page (www.domain.com/hompage.aspx).  But how do you go about not having that page appear in the url so if you go to www.domain.com it shows the contents of what ever the default page is, basically the similar functionality of a default file in a sub directory (index.aspx).  I looked into url rewriting and haven't had any luck to get it to rewrite to the root level of the domain.  I also tried urlmappings in the web.config.  Not sure which is the correct route to go.  Thanks.
  2. Chris Avenick
    Chris Avenick avatar
    4 posts
    Registered:
    01 Dec 2009
    09 Dec 2009
    Link to this post
    Through researching I found this post.  http://www.sitefinity.com/support/forums/sitefinity-3-x/general-discussions/don-t-want-homepage-redirected-how.aspx .  Which explains how to do this.  The only thing is that it doesn't seem to be working in my set up because I have extensionless urls on my pages by setting a wildcard in IIS and changing the cms tag in the web.config to have pageExtension="" . 

    I tried following these steps in this post and got it to work when i didn't have extensionless urls  and created an index.aspx file in the root folder then created a page in SF and named it index.aspx.  It just didn't work if i had extensionless urls and created a file index and set that in IIS as default.

    Any ideas if this could work with extensionless urls?
  3. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    10 Dec 2009
    Link to this post
    Hi Chris Avenick,

    Please try to remove the default document from IIS, which you set, or just leave the default one (default.aspx). Then set a home page through the UI of Sitefinity, and disable the page redirect from the web.config file. This should do it. 

    Let me know if you receive different results. 

    Greetings,
    Georgi
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  4. Chris Avenick
    Chris Avenick avatar
    4 posts
    Registered:
    01 Dec 2009
    10 Dec 2009
    Link to this post
    Thank you for your quick response.  I removed the default document from IIS and removed all the url rewriting updates and the urlmappings updates to the web.config.  I then set my page as the home page in the UI of Sitefinity.  When I go to the root level of the domain it redirects to the home page that I set through the UI.   What were you referring to about disabling the redirect in the web.config file, which section is it in?  Thanks again for all your help.
  5. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    10 Dec 2009
    Link to this post
    Hello Chris Avenick,

    I was referring to:

    web.config

    <cms defaultProvider="Sitefinity"
     redirectToHomePage="false"
     pageExtension=".aspx"
     ..

    If you do not have the property in the config file, please add it and set it to false.

    Best wishes,
    Georgi
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
    Answered
  6. Chris Avenick
    Chris Avenick avatar
    4 posts
    Registered:
    01 Dec 2009
    10 Dec 2009
    Link to this post
    Thanks Georgi, that worked!
Register for webinar
6 posts, 1 answered