More in this section

Forums / Developing with Sitefinity / Extensionless URLs in SF 3.7.2 with .aspx

Extensionless URLs in SF 3.7.2 with .aspx

4 posts, 0 answered
  1. Jon
    Jon avatar
    22 posts
    Registered:
    11 Mar 2010
    02 Apr 2010
    Link to this post
    I have Corporate instance of SF 3.7.2 running on a Windows 2008 Server with IIS with a Classic managed pipeline config.

    I require the following:

    Current pages must load as .aspx and additional added Page URLs added to the Page Properties such as:

    ~/pbs
    ~/pbs/


    I've read the updated 3.7 User Manual and implemented:
    the 404 change to our existing /sf404.aspx
    making the default error response to Custom error pages
    the Wildcard Application Mappings changes.
    web.config

        <customErrors mode="On" defaultRedirect="~/sf404.aspx">
          <error redirect="~/sf404.aspx" statusCode="404" />
        </customErrors>

            <cms defaultProvider="Sitefinity" pageExtension=".aspx" additionalExtensions=".html, .cfm, .zhtml, ." siteTemplate="" projectName="CorporateInternet" disabled="false" pageEditorUIMode="Overlay">



    I've read the threads here and they seem to be related to older versions or are very old.

    Hopefully, there's a simple solution that will:

    - Keep pages with their .aspx extension - http://domain/page.aspx
    - Allow additional user speficied "Page URLs" to load the desired target page.




  2. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    05 Apr 2010
    Link to this post
    Hi Jon,

    Thank you for posting your question. 

    Please remove any entries in the web.config file and in the IIS configuration related to the sf404.aspx page. Then, add a wildcard script mapping - all requests should be handled by Asp.Net ISAPI (screenshot attached). 

    The web.config should be configured as following:

    <cms defaultProvider="Sitefinity"
     pageExtension=".aspx"
     projectName="sp3"
     disabled="false"
     ...

    This way you will be able to create pages with aspx pages by default, but you will also be able to access them without extension, and with trailing slash (due to the wildcard). 

    Example:

    User is creating page test.aspx. Accessible url become:

    • site.com/test.aspx
    • site.com/test
    • site.com/test/

    I hope this helps. 

    Greetings,
    Georgi
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  3. Jon
    Jon avatar
    22 posts
    Registered:
    11 Mar 2010
    12 Apr 2010
    Link to this post
    Thank you for the response.  This didn't resolve the issue. Allow me to clarify

    We have a page:

    http://www.site.com/content1/content2/default.aspx

    The page properties list several additional: Page URLs

    Another URL: ~/ABBR
    Another URL: ~/ABBR/
    Another URL: ~/A-B-B-R/
    Another URL: ~/A-B-B-R


    Based off your direction, my web.config is now:

    <customErrors mode="On" />
     
     
    <cms defaultProvider="Sitefinity" pageExtension=".aspx" additionalExtensions=".html, .cfm, .zhtml" siteTemplate="" projectName="CorporateInternet" disabled="false" pageEditorUIMode="Overlay">


    The wildcard mapping is to: C:\Windows\Microsoft.NET\Framework\v2.0.50727\aspnet_isapi.dll

    I've removed the sf404.aspx refs in IIS and web.config.


    I need the various Another URL to work correctly.





    Thanks,

    -Jon

  4. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    Registered:
    01 Feb 2016
    14 Apr 2010
    Link to this post
    Hello Jon,

    We have sent a response to the support ticket you have opened with the same issue. For the convenience of other forum members here is our response:

    Unfortunately how the sf404.aspx and default page extension work in a bit different way. For example if you want to set the default extension to be .aspx, so that the default url would be ~/home.aspx, however you still want it to be accessible from ~/home or ~/additonalurl you should add the additional url as ~/additionalurl.aspx. Then since you have sf404.aspx setup it will serve the same page even without the extension entered. Please refer to attached screen cast.

    Greetings,
    Radoslav Georgiev
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
Register for webinar
4 posts, 0 answered