More in this section

Forums / Developing with Sitefinity / Extensionless with extensions issue?

Extensionless with extensions issue?

3 posts, 0 answered
  1. Matthew
    Matthew avatar
    33 posts
    Registered:
    15 Dec 2008
    09 Jul 2009
    Link to this post
    Here is my issue:
     
    - Community Edition 3.5 
    - Local Environment = IIS7
    - Beta Enviroment = IIE6 (discountasp)

    In development I can hit any page without the extension with no error - ie: localhost/restaurant (this displays the 'restaurant.aspx' page setup in the CMS.

    In beta when i try hitting "domain/restaurant" the server throws a 404 error. I can however hit the page at "domain/restaurant.aspx".

    I've been back and forth setting default documents, etc in beta with no luck.

    Any help on this would be great. Ideally i'd like to hit both pages with and without the extension.

    Thanks, Matt
  2. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    Registered:
    01 Feb 2016
    09 Jul 2009
    Link to this post
    Hi Matthew,

    Thank you for using our services.

    Can you please check the IIS custom error configuration on your beta server. you have to provide custom redirection for 404 pages, be point to ~/YourSite/sf404.aspx. To do this in IIS 6.x, please follow these steps:

    1.Click All Programs > Administrative Tools> Internet Information Servicees (ISS) Manager.
    2.Expand the tree on the left until you see Web Sites > Default Web Site.
    3.Expand the the Default Web Site folder.
    4. Right click your project folder and select Properties.
    5.On the Custom Errors tab, select HTTP error 404.
    6.Click Edit.
    7.From the Message Type list, choose URL.
    8. In the URL field, type the path to sf404.aspx in your project - /Project/sf404.aspx.
    9.Click OK.

    If you are not able to configure the IIS settings on your beta machine you can also configure the custom errors in your web.config file like that:

    <customErrors mode="On"
          ... 
          <error redirect="~/sf404.aspx" statusCode="404"/> 
          ... 
    </customErrors> 

    Please, see if the above will help solve that issue. If you have more questions feel free to contact us.

    Greetings,
    Rado
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
  3. Matthew
    Matthew avatar
    33 posts
    Registered:
    15 Dec 2008
    09 Jul 2009
    Link to this post
    the IIS change worked like a charm. thanks again for the quick reply!

    Matt
Register for webinar
3 posts, 0 answered