More in this section

Forums / Developing with Sitefinity / New module not showing up in Modules menu

New module not showing up in Modules menu

3 posts, 0 answered
  1. Richard Murphy
    Richard Murphy avatar
    6 posts
    Registered:
    23 Mar 2006
    27 Jan 2009
    Link to this post
    I am trying to implement the sample products module (the one that demo's how to create a generic content based module). I have followed all the instructions including adding all the references it says to add to register the module in the web.config. This does include the adding of:
    <add type="Telerik.Samples.Products.ProductsModule, Telerik.Samples.Products" />
    to the framework -> modules section.
    The main difference is that I have included the product module within my project rather than have it as a separate project. It all compiles fine BUT the products module does not show up on the Modules menu in the admin area with the other modules (i.e. News, Events etc)

    Am I missing something obvious? Oh - one other point - our sitefinity project has been changed to a project based application rather than a website so I do not have an app_code folder.

    Thanks in advance,

    Richard
  2. Richard Murphy
    Richard Murphy avatar
    6 posts
    Registered:
    23 Mar 2006
    28 Jan 2009
    Link to this post
    OK - I solved it. I just needed to change the assembly name in the web config entries so they were now the assembly name of the project I was including them in. I also had to recreate the resource files.


  3. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    28 Jan 2009
    Link to this post
    Hello Richard Murphy,

    We are glad that you have it working.
    Don't hesitate to contact us if you have other questions.

    Best wishes,
    Georgi
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
Register for webinar
3 posts, 0 answered