More in this section

Forums / Developing with Sitefinity / Problem with QueryString in SItefinity

Problem with QueryString in SItefinity

3 posts, 0 answered
  1. Neeraj
    Neeraj avatar
    1 posts
    Registered:
    27 Apr 2009
    27 Apr 2009
    Link to this post

    Hi All,

            I am having a problem with a querystring. I have one key pair value like

    www.xyz.com?id=9

    Now this works fine. Now the id can repeat again as the page gets filtered by the Ids in the querystring. as follows

    www.xyz.com?id=9&id=11

    Now when i say Request.QueryString["id"] then it returns 9,11 in the normal asp.net website.

    But when i use the same code on the sitefinity project its not doing same. its returning "9id=11" (and some how sitefinity is stripping the & in the url) . and this is causing errors in my code. As my code runs successfully only if it returns 9,11

    CAN ANYONE HELP ME OUT IN THIS ASPECT.

     MNK...

  2. Gabe Sumner
    Gabe Sumner avatar
    440 posts
    Registered:
    09 Sep 2007
    27 Apr 2009
    Link to this post
    I just tested this with 3.6 SP1 and confirmed this.  Neeraj, I think you discovered an issue.

    In the meantime, here is a really lame workaround:

    string idParams = Request.QueryString["id"].Replace("id=", ",");

  3. Vlad
    Vlad avatar
    498 posts
    Registered:
    19 Jun 2017
    28 Apr 2009
    Link to this post
    Yes, this is a bug.

    Fortunately, we are going to release a Hotfix till the end of the week (hopefully tomorrow). It will address an issue with resolving dynamic links for items in the Images&Documents in a non-shared generic content on a page.

    The fix for this issue will be included in the build as well.

    Neeraj,  we updated your telerik points for reporting this problem.

    Kind regards,
    Vlad
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
Register for webinar
3 posts, 0 answered