More in this section

Forums / Developing with Sitefinity / RadWindowManager presentation problem with prometheus

RadWindowManager presentation problem with prometheus

2 posts, 0 answered
  1. Luc Baeten
    Luc Baeten avatar
    169 posts
    Registered:
    23 Sep 2005
    23 Apr 2008
    Link to this post
    Hello Sitefinity team

    When I use the following code

    <%@ Control Language="VB" AutoEventWireup="false" CodeFile="ActionButton.ascx.vb" Inherits="UserControls_ActionButton" %>
    <%
    @ Register Assembly="Amarantin.WebPack2" Namespace="Amarantin.WebPack2.WebControls" TagPrefix="WebPack2" %>
    <%
    @ Register tagprefix="radW" namespace = "Telerik.WebControls" assembly="RadWindow.Net2" %>
    <radW:RadWindowManager ID="RadWindowManager1" Behavior="Close,Maximize,Move,Resize" Skin="Vista" VisibleStatusbar="true" VisibleTitlebar="true" runat="server">
        
    <Windows>
        <radW:RadWindow ID="UserListDialog" runat="server" Title="User List Dialog" Height="400px"Width="300px" Left="150px" ReloadOnShow="true" Modal="true" /></Windows>
    </
    radW:RadWindowManager>
    <
    WebPack2:ImageTextButton Id="uxImageTextButton" Runat="server">
        
    <WebPack2:ImageItem Id="uxImageButton" backimagesetting="Repeat" Wrap="false" Width="0" Height="26" font="Arial, 9pt, style=Bold" imageformat="Jpeg" antialias="True" Padding="0,10,0,10" VerticalAlign="Middle" HorizontalAlign="Center" Visible="False" JpegQuality="100" ImageType="Normal" />
        
    <WebPack2:ImageItem ImageType="MouseOver" CopyFromItem="uxImageButton" />
    </
    WebPack2:ImageTextButton>


    with the old RadWindow.NEt2.dll the presentation of my popup window is looking good. This window is presented when clicking on the uxImageTextButton.

    However when I use the same code with the prometheus dll

    <%@ Control Language="VB" AutoEventWireup="false" CodeFile="ActionButton.ascx.vb" Inherits="UserControls_ActionButton" %>
    <%
    @ Register Assembly="Amarantin.WebPack2" Namespace="Amarantin.WebPack2.WebControls" TagPrefix="WebPack2" %>
    <%
    @ Register TagPrefix="telerik" Namespace="Telerik.Web.UI" Assembly="Telerik.Web.UI" %>
    <telerik:RadWindowManager ID="RadWindowManager1" Behavior="Close,Maximize,Move,Resize" Skin="Default" VisibleStatusbar="true" VisibleTitlebar="true" runat="server">
    <Windows>
    <telerik:RadWindow ID="UserListDialog" runat="server" Title="User List Dialog" Height="400px" Width="300px" Left="150px" ReloadOnShow="true" Modal="true" />
    </Windows>
    </
    telerik:RadWindowManager>
    <
    WebPack2:ImageTextButton Id="uxImageTextButton" Runat="server">
        
    <WebPack2:ImageItem Id="uxImageButton" backimagesetting="Repeat" Wrap="false" Width="0" Height="26" font="Arial, 9pt, style=Bold" imageformat="Jpeg" antialias="True" Padding="0,10,0,10" VerticalAlign="Middle" HorizontalAlign="Center" Visible="False" JpegQuality="100" ImageType="Normal" />
        
    <WebPack2:ImageItem ImageType="MouseOver" CopyFromItem="uxImageButton" />
    </
    WebPack2:ImageTextButton>

    I am getting a popup window that is mixed up: The titlebar is divided in two with one part transparent. Also no dragg grey background is shown when this popup is dragged around the screen.

    What should i do to solve this problem?

    Regards
    Luc Baeten
  2. Pepi
    Pepi avatar
    981 posts
    Registered:
    31 Jan 2017
    25 Apr 2008
    Link to this post
    Hi Luc Baeten,

    Unfortunately, we cannot reproduce any problem with the appearance of RadWindow "Prometheus". What browser do you use and what version?

    Please look at the following online example that might be useful for you. Also:

    1. Check if your custom css does not break the layout.
    2. Note that you are using different Skins for the RadWindows. In the first example it is "Vista" and in the second one it is the "Default" skin.

    Hope this will help in solving the issue.

    Regards,
    Pepi
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
2 posts, 0 answered