More in this section

Forums / Developing with Sitefinity / RSS Problem (This feed contains code errors)

RSS Problem (This feed contains code errors)

6 posts, 0 answered
  1. Kutay
    Kutay avatar
    18 posts
    Registered:
    21 Apr 2009
    15 Jun 2009
    Link to this post
    Hello,

    I've set up a RSS feed for the news items as it is shown in the demo videos. But when I click the feed link, i get an error saying "This feed contains code errors" and in the more info section it says "An invalid character was found in text content".

    The news items contain Turkish characters, I guess that's why I get an error. Is there a solution for this?

    Thank you in advance...
  2. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    15 Jun 2009
    Link to this post
    Hi Kutay,

    Could you please let us know about the exact Sitefinity version that you use? We added the UTF-8 support for the RSS items in Sitefinity 3.6, so you might try to upgrade and see if that will fix the issues are having.

    All the best,
    Georgi
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
  3. Kutay
    Kutay avatar
    18 posts
    Registered:
    21 Apr 2009
    15 Jun 2009
    Link to this post
    Hi Georgi,

    I'm using Sitefinity 3.6 SP1. The problem is that, I had a problem with special characters in the user controls that I added, so I changed the <globalization> settings to use "Windows-1254" encoding. Then the character problem was solved.

    But now I want to use the RSS service, and to do that I need to change the encoding again which will mess up the text in my user controls. What should I do here?

    Thanks.
  4. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    16 Jun 2009
    Link to this post
    Hi Kutay,

    Please try to use UTF-8 encoding for your application. It will have both the special characters and the latin characters. What happens with the feed if you remove the globalization elements?

    Sincerely yours,
    Georgi
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
  5. Kutay
    Kutay avatar
    18 posts
    Registered:
    21 Apr 2009
    16 Jun 2009
    Link to this post
    Hi,

    When I change the encoding to UTF-8, the RSS problem is solved. But still, the addresses of the news items which contain special characters (AND my user controls) are not displayed properly.

    How do I solve these problems?

    Thank you in advance.
  6. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    17 Jun 2009
    Link to this post
    Hi Kutay,

    Do you mean that you have non-latin characters in the news titles for example? The titles most probably take part of the url, so if you have any non latin characters, you might end up with unresolved url or an ugly looking one (due to the url encoding).

    I suggest you the following - add a new meta field for your news items. Then, this metafield will serve as the real title - with all the special characters. In the original Title though, you could use only latin characters.

    What do you think about this?

    All the best,
    Georgi
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
Register for webinar
6 posts, 0 answered