More in this section

Forums / Developing with Sitefinity / SiteFinity errors within /sitefinity folder AGAIN

SiteFinity errors within /sitefinity folder AGAIN

14 posts, 0 answered
  1. Nathan J Pledger
    Nathan J Pledger avatar
    27 posts
    Registered:
    21 Apr 2006
    27 Sep 2009
    Link to this post
    And guess what. After my previous problems using this CMS (including .ascx files of yours not compiling despite all code being present) I get more problems.

    I resolved the issue described at http://www.sitefinity.com/support/forums/sitefinity-3-x/developing-with-sitefinity/solution-not-compiling.aspx (also experienced bya number of other users) by hiding the files, which prevents VS from "seeing" the files for compiling. All worked fine. Now, this morning, so very close to finishing working with this CMS, I now get:
     

    Server Error in '/' Application.

    Parser Error

    Description: An error occurred during the parsing of a resource required to service this request. Please review the following specific parse error details and modify your source file appropriately.

    Parser Error Message: The resource object with key 'ProjectName' was not found.

    Source Error:

    Line 44:     <form id="form1" runat="server">
    Line 45:     <div id="loginBox">
    Line 46: <h1><span>Site Finity |</span><strong id="projectName" runat="server"><asp:Literal runat="server" Text="<%$Resources:ProjectName %>"></asp:Literal></strong></h1>Line 47:         <h2><asp:Literal runat="server" Text="<%$Resources:Login %>"></asp:Literal></h2>
    Line 48:         <asp:Login ID="Login1" runat="server" DestinationPageUrl="Admin/Default.aspx">

    When I try to log in to the local dev site on my machine.

    I tried re-"showing" the files in the /sitefinity folder by resetting the Hidden flag and this still fails.

    This is beyond the pale. NOTHING HAS CHANGED from the Sitefinity 3.6 install within the /sitefinity folder. How can this happen? It's having serious impact on our deadlines and I'm seriously considering actively telling people to avoid this product.

    It's a real shame, your other products are first class and I have been a subscriber of those for a number of years now both on a personal basis (at my own cost) and professionally through my employers.
  2. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    28 Sep 2009
    Link to this post
    Hi Nathan J Pledger,

    Thank you for your feedback - we appreciate it, and look on it in a constructive way.

    It is true that there are problems in the newsletters templates, but we have provided guidances (which I understood helped you) in the forum thread you mentioned. We are not doing changes in this templates since several versions, and actually have received way to few complaints about them. We will to fix them for the next release.

    As for the error you reported here - could you please double check this control? I do not think that this is control we distribute, and if it is not ours, most likely the resource files are also custom ones. 

    I am looking forward for your notes on this. 

    Greetings,
    Georgi
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  3. Nathan J Pledger
    Nathan J Pledger avatar
    27 posts
    Registered:
    21 Apr 2006
    11 Oct 2009
    Link to this post
    Hi Georgi,

    The full error message (apologies, I ommitted the last line) is:

    Server Error in '/' Application.

    Parser Error

    Description:An error occurred during the parsing of a resource required to service thisrequest. Please review the following specific parse error details and modifyyour source file appropriately.

    Parser Error Message: Theresource object with key 'ProjectName' was not found.

    SourceError:

    Line 44:     <form id="form1" runat="server">Line 45:     <div id="loginBox">Line 46:         <h1><span>Site Finity |</span><strong id="projectName" runat="server"><asp:Literal runat="server" Text="<%$Resources:ProjectName %>"></asp:Literal></strong></h1>Line 47:         <h2><asp:Literal runat="server" Text="<%$Resources:Login %>"></asp:Literal></h2>Line 48:         <asp:Login ID="Login1" runat="server" DestinationPageUrl="Admin/Default.aspx">

    SourceFile: /sitefinity/login.aspx    Line: 46


    Version Information: Microsoft .NET Framework Version:2.0.50727.4927;ASP.NET Version:2.0.50727.4927 


    which specifically states the error being in /siteifnity/login.aspx.


  4. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    12 Sep 2017
    11 Oct 2009
    Link to this post
    Hi Nathan J Pledger,

    Please check whether you have the following resource file Login.aspx.resx under ~/Sitefinity/App_LocalResources. The error is thrown because the resource file and ProjectName key cannot be found.
    If the resx file exists make sure that it looks like as shown below:

     Name                                              Value
    Login Login
    LoginCaps LOGIN
    Password Password
    PasswordEmpty Password is required.
    ProjectName Project Name
    RememberMeOnThisComputer Remember me on this computer
    Username Username
    UsernameEmpty Username is required.


    Kind regards,
    Ivan Dimitrov
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  5. Drew Peloubet
    Drew Peloubet avatar
    10 posts
    Registered:
    06 Oct 2008
    05 Jan 2010
    Link to this post
    Hello,

    I am experiencing the same error as reported above and have verified both the resource files and keys do exist. Is there any update on how to resolve this?

    Thanks.
  6. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    12 Sep 2017
    05 Jan 2010
    Link to this post
    Hi Drew Peloubet,

    If you remove the resource key Text="<%$Resources:ProjectName %>"> and just set a text are you getting the error message? By doing so we will narrow the problem.

    Regards,
    Ivan Dimitrov
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  7. Drew Peloubet
    Drew Peloubet avatar
    10 posts
    Registered:
    06 Oct 2008
    05 Jan 2010
    Link to this post
    I then get this error: The resource object with key 'Login' was not found.
  8. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    12 Sep 2017
    06 Jan 2010
    Link to this post
    Hello Drew Peloubet,

    I am not able to reproduce any problem with the resources. Possible reasons for the error you are getting are:

    - name of  the Resource object is not correct
    - Resource file is not in the correct place

    It seems that all resource names are not related to the resx file tyou should have in App_LocalResources folder. Could you upload the attached files to your project and let us know whether you are able to reproduce this issue.

    Kind regards,
    Ivan Dimitrov
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  9. Drew Peloubet
    Drew Peloubet avatar
    10 posts
    Registered:
    06 Oct 2008
    06 Jan 2010
    Link to this post
    I dropped those files in and it got me past the login page, but I immediately get: The resource object with key 'ProjectLabel' was not found.

    I agree it's obvious that something is consistently wrong with the resource files. I also get a similar error in a different client login area of the site. Do have any suggestions of how to "refresh" all these files without losing any custom pages / configuration in our site?

    Thanks.
  10. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    12 Sep 2017
    06 Jan 2010
    Link to this post
    Hello Drew Peloubet,

    There is not automated process - you should go to each Resource file and check whether everything is set correctly.

    Sincerely yours,
    Ivan Dimitrov
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  11. Drew Peloubet
    Drew Peloubet avatar
    10 posts
    Registered:
    06 Oct 2008
    06 Jan 2010
    Link to this post
    Unfortunately I've gone through every occurrence of the resource object error and verified both the path is correct and the keys exist in the resource files. Still running into errors. It does seem they are all related to the admin login however, as the rest of the site works.

    For clarification, this is a full production copy being restored to a "test" machine for dev purposes. All versions are the same and there are other Sitefinity sites running locally. In other words, other local sites are working. It's just something with this particular site? Any other suggestions? Thanks.
  12. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    12 Sep 2017
    06 Jan 2010
    Link to this post
    Hi Drew Peloubet,

    I am run out of ideas. If you could send a sample project to see what is going on it will be great. Most probably you have set something that breaks the resource access. You can take at the following links to see whether there is any change that is different from the default one -  Resources and Localization in ASP.NET 2.0

    Regards,
    Ivan Dimitrov
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  13. Drew Peloubet
    Drew Peloubet avatar
    10 posts
    Registered:
    06 Oct 2008
    06 Jan 2010
    Link to this post
    I will take a look. One final request. Your developer manual on the main support page (.chm file) doesn't seem to work. Any link you click inside it displays "page cannot be displayed" or "navigation was cancelled". I had someone else confirm as well. Do you have a working version of that help file available? And a 3.7 version?
  14. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    12 Sep 2017
    06 Jan 2010
    Link to this post
    Hello Drew Peloubet,

    The links do work. The error page you see is most probably caused by the security policy in Windows. To bypass it, right-click, properties. In the General tab, you will see an “unblock” button.

    All the best,
    Ivan Dimitrov
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
Register for webinar
14 posts, 0 answered