More in this section

Forums / Developing with Sitefinity / Static and Library I mage

Static and Library I mage

11 posts, 0 answered
  1. Steven Reid
    Steven Reid avatar
    16 posts
    Registered:
    27 Jan 2010
    19 Feb 2010
    Link to this post
    Hi,

    I have made all the changes stated in my earlier post.
    http://www.sitefinity.com/support/forums/sitefinity-3-x/developing-with-sitefinity/access-images-from-library-via-silverlight.aspx

    However , an unexpected side affect has been that all my theme and skin images sprite.png etc are not being found.

    I understand that this is because I am now mapping my .jpg and .png requests. Is there a setting that if the aspx cannot serve the file then it would get it from the physical path.

    Thanks

    Steven
  2. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    19 Feb 2010
    Link to this post
    Hi Steven Reid,

    Unfortunately there is no such setting, but you can override the default ContentHandlers and implement it there. Here's how the handler is defined in the configuration file:

    <add name="SitefinityLibrary" path="*.sflb" verb="*" preCondition="integratedMode" type="Telerik.Cms.Engine.ContentHttpHandler, Telerik.Cms.Engine" />

    When you create your new handler, you should define in the same way and remove the old one. 

    I hope this helps. 

    Regards,
    Georgi
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  3. Steven Reid
    Steven Reid avatar
    16 posts
    Registered:
    27 Jan 2010
    19 Feb 2010
    Link to this post
    Georgi,
    Thanks for the help but I found a simpler solution.

    I am using II6 and under the mappings tab for the virtual directory I clicked Insert next to the wildcard application map.

    I then added the
    C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\aspnet_isapi.dll
    followed by the
    C:\WINDOWS\system32\inetsrv\ssinc.dll

    It now works.

    Steven
  4. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    19 Feb 2010
    Link to this post
    Hello Steven Reid,

    Great to hear it. This surelly can serve as a tip :)

    Best wishes,
    Georgi
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  5. Steven Reid
    Steven Reid avatar
    16 posts
    Registered:
    27 Jan 2010
    19 Feb 2010
    Link to this post
    Better scrap that.

    My "fix" caused 
     "Error handling SSI File : Win32 Error Code = 87"

    to be displayed when logging into the admin package.

    There must be a fix for this , because all the images for the admin login screen have disappeared as well.

    Has anyone else had this or a similar problem enabling  images to show their correct file extension ?

    Cheers

    Steven
  6. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    22 Feb 2010
    Link to this post
    Hi Steven Reid,

    Do you need ssinc.dll for this project? If not, removing it will fix the error, but still, I am not sure that the images will show up. 

    Kind regards,
    Georgi
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  7. Steven Reid
    Steven Reid avatar
    16 posts
    Registered:
    27 Jan 2010
    22 Feb 2010
    Link to this post
    Georgi ,
    I have removed the wildcard and the Admin package works. However, I am back to square one because any Image with a physical path is no longer being displayed.

    What do I need to do ?

    Steven
  8. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    22 Feb 2010
    Link to this post
    Hi Steven Reid,

    This really should not be the case. Can you please let me know about the status of the responses, when you request an image?

    Best wishes,
    Georgi
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  9. Steven Reid
    Steven Reid avatar
    16 posts
    Registered:
    27 Jan 2010
    25 Feb 2010
    Link to this post
    Georgi ,

    Sorry for the delay.

    I was expecting  404 errors , but I am actually getting "Cannot Find Server" errors. I have checked with fiddler and it is returning  Http Code 0.

    Any ideas , Have I missed some configuration step?

    Cheers

    Steven
  10. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    25 Feb 2010
    Link to this post
    Hello Steven Reid,

    Thank you for the follow up. 

    Http Status code 0 means that the response is empty. There is no even not found error, which leads me to the thought that the request does not reach the static file handler (the physical files on the file system). 

    When a request comes to Asp.Net, it goes through all modules registered in the application, but not through all handlers - it stops on the first handler that matches the rule of processing. Therefore, I think that there is something wrong in the web.config file and the configuration as a whole - a handler is handling the request before it reaches the Static File handler, and is not giving any response. 

    Could you please check if you have by any chance changed the extensions that ContentHttpHandler is processing:

    <httpHandlers>
    ...
         <add verb="*" path="*.sflb" type="Telerik.Cms.Engine.ContentHttpHandler, Telerik.Cms.Engine"/>
         <add verb="*" path="*.sflb.ashx" type="Telerik.Cms.Engine.ContentHttpHandler, Telerik.Cms.Engine"/>
         <add verb="*" path="*.tmb" type="Telerik.Cms.Engine.ContentHttpHandler, Telerik.Cms.Engine"/>
         <add verb="*" path="*.tmb.ashx" type="Telerik.Cms.Engine.ContentHttpHandler, Telerik.Cms.Engine"/>

    These handlers should process only the sflb.ashx and tmb.ashx requests, but not jpg and other real images formats. You should not have the real file formats specified here. 

    For any case, you can send me the web.config file so we can check all settings.

    I hope this helps or could point you in the right direction. 

    Regards,
    Georgi
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  11. Steven Reid
    Steven Reid avatar
    16 posts
    Registered:
    27 Jan 2010
    01 Mar 2010
    Link to this post
    Now Solved.

    Placed a wild card mapping to the .net framework only and removed the mappings for Jpeg and Png.

    Worked for me.

    Thanks once again Georgi.

    Steven
Register for webinar
11 posts, 0 answered