More in this section

Forums / General Discussions / Upgrade from 4.1 to 4.2

Upgrade from 4.1 to 4.2

3 posts, 1 answered
  1. Charles
    Charles avatar
    61 posts
    Registered:
    18 Jul 2012
    29 Nov 2011
    Link to this post

    Hi, I just upgraded a 4.1 site to 4.2 and it upgraded process went ok, but then I attempt to run the project with the project manager and before the site even loads in a browser I receive this message.

    Could not load file or assembly 'Telerik.Sitefinity, Version=4.1.1395.0, Culture=neutral, PublicKeyToken=b28c218413bdf563' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)

  2. Markus
    Markus avatar
    2763 posts
    Registered:
    25 Nov 2005
    29 Nov 2011
    Link to this post
    Dear Charles

    1395 is the number the number of 4.1 SP1.

    Any custom code or controls in your solution that were build against that and would need to be updated.
    Markus
  3. Victor Velev
    Victor Velev avatar
    1345 posts
    Registered:
    06 Jul 2015
    29 Nov 2011
    Link to this post
    Hi Charles,

    As Markus suggested, the problem may be coming from custom controls of yours which need to be built using the new assemblies.

    The following article may be useful to you:

    http://www.sitefinity.com/devnet/forums/sitefinity-4-x/bugs-issues/upgrade-to-from-4-2-to-4-2-sp1-problem.aspx

    All the best,
    Victor Velev
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
    Answered
3 posts, 1 answered