More in this section

Forums / General Discussions / Forgot Password - reset and send email

Forgot Password - reset and send email

2 posts, 0 answered
  1. Pat
    Pat avatar
    8 posts
    18 Jan 2011
    25 Aug 2011
    Link to this post

    I'm trying to get the Forgot Password control to reset and send an email, just the out of the box, Sitefinity login control.

    Passwords are not set to hash, enablePasswordReset & enablePasswordRetrieval are both set to true. 
    I have confirmed SMTP details.

    While the control says it is sent, i dont receive any email.

    Through inspecting the error logs i've found this error ('ErrorMessageTheSysIsNotPermittedToSendEmailsText)

    Can anyone help me with getting this to work? I am running 4.1.1395.0  Standard Edition,

    Timestamp: 8/25/2011 12:12:56 AM

    Message: HandlingInstanceID: 90dc9e1d-4fe6-42db-85db-52cdab720157
    An exception of type 'System.Reflection.TargetInvocationException' occurred and was caught.
    08/25/2011 10:12:56
    Type : System.Reflection.TargetInvocationException, mscorlib, Version=, Culture=neutral, PublicKeyToken=b77a5c561934e089
    Message : Property accessor 'ErrorMessageTheSysIsNotPermittedToSendEmailsText' on object 'Telerik.Sitefinity.Web.UI.PublicControls.LoginControl' threw the following exception:'Object reference not set to an instance of an object.'
    Source : System
    Help link :
    Data : System.Collections.ListDictionaryInternal
    TargetSite : System.Object GetValue(System.Object)
    Stack Trace :    at System.ComponentModel.ReflectPropertyDescriptor.GetValue(Object component)
       at Telerik.Sitefinity.Modules.Pages.PropertyPersisters.ObjectDataUtility.GetPropertyValue(PropertyDescriptor descriptor, Object component)

    Additional Info:

    MachineName : SKNET143
    TimeStamp : 8/25/2011 12:12:56 AM
    FullName : Telerik.Sitefinity.Utilities, Version=4.1.1395.0, Culture=neutral, PublicKeyToken=b28c218413bdf563
    AppDomainName : /LM/W3SVC/149/ROOT/SP-AusNet-1-129587017054514758
    ThreadIdentity : mintleaf
    WindowsIdentity : SKNET143\spausnetbtsauc_web
    Requested URL : /SP-AusNet/Sitefinity/Services/Pages/ControlPropertyService.svc/batch/ec6ce9ab-b6de-4533-a08f-976e39b6f7ed/?pageId=c2d0fb4d-bf41-4131-9e60-eab2c35e96ee&mediaType=Page&checkLiveVersion=False&upgradePageVersion=False
        Inner Exception
        Type : System.NullReferenceException, mscorlib, Version=, Culture=neutral, PublicKeyToken=b77a5c561934e089
        Message : Object reference not set to an instance of an object.
        Source : Telerik.Sitefinity
        Help link :
        Data : System.Collections.ListDictionaryInternal
        TargetSite : System.String get_ErrorMessageTheSysIsNotPermittedToSendEmailsText()
        Stack Trace :    at Telerik.Sitefinity.Security.Web.UI.LoginForm.get_ErrorMessageTheSysIsNotPermittedToSendEmailsText()

    Category: ErrorLog

    Priority: 0

    EventId: 9010

    Severity: Warning

    Title:Enterprise Library Exception Handling

    Machine: SKNET143

    App Domain: /LM/W3SVC/149/ROOT/SP-AusNet-1-129587017054514758

    ProcessId: 2624

    Process Name: C:\Windows\SysWOW64\inetsrv\w3wp.exe

    Thread Name:

    Win32 ThreadId:31180

    Extended Properties: 
  2. Ivan Pelovski
    Ivan Pelovski avatar
    43 posts
    24 Sep 2012
    30 Aug 2011
    Link to this post
    Hi Pat,

    We tried to reproduce your problem with password retrieval but everything worked fine. The log entry you have pasted is not related with the password retrieval but rather with the work of the Page Editor. Could you check again your SMTP settings and check if your mails are not blocked by the SMTP server?

    All the best,
    Ivan Pelovski
    the Telerik team

    Thank you for being the most amazing .NET community! Your unfailing support is what helps us charge forward! We'd appreciate your vote for Telerik in this year's DevProConnections Awards. We are competing in mind-blowing 20 categories and every vote counts! VOTE for Telerik NOW >>

2 posts, 0 answered