More in this section

Forums / General Discussions / Fresh 4.2 Insall - Active Directory

Fresh 4.2 Insall - Active Directory

6 posts, 0 answered
  1. Bradley
    Bradley avatar
    3 posts
    Registered:
    11 Oct 2011
    13 Oct 2011
    Link to this post
    I have just installed a fresh version of version 4.2 and would like to connect to Active Directory for CMS login etc.  I have made the relevant changes to the web.config (connection strings, TelerikADMembershipProvider, TelerikADRoleProvider etc.).  However, when I attempt to run the project I get the following error.

    Configuration Error

    Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

    Parser Error Message: Could not load file or assembly 'Telerik.Security' or one of its dependencies. The system cannot find the file specified.

    Source Error:

    Line 47: 			connectionPassword="kavike5r4" 
    Line 48: 			groupMaps="Administrators" 
    Line 49: 			type="Telerik.Security.ActiveDirectory.TelerikADRoleProvider, Telerik.Security" /> 
    Line 50:       	</providers> 
    Line 51:     </roleManager> 

    Source File: D:\AreaPagePOC\AreaPOC\web.config    Line: 49

    Assembly Load Trace: The following information can be helpful to determine why the assembly 'Telerik.Security' could not be loaded.

    When I then go look in the \bin directory, Telerik.Security.dll is not there.  Is the something I have done wrong during the installation process or what am I missing?

    Thanks
    Bradley


  2. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    Registered:
    01 Feb 2016
    17 Oct 2011
    Link to this post
    Hello Bradley,

    The configuration that you are adding looks like the one which is relevant of the older version of Sitefinity (Sitefinity 3.x). If you are on Sitefinity 4.x version, please refer to this article.

    Best wishes,
    Radoslav Georgiev
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Bradley
    Bradley avatar
    3 posts
    Registered:
    11 Oct 2011
    17 Oct 2011
    Link to this post
    Hi Radoslav

    Thanks for your response.  I have now removed all these settings from the config files  and attempted to configure the site through the Advanced - Settings - LDAP settings UI, however, I have been unsuccessful.

    I am trying to connect to Novell eDirectory using LDAP (not Microsoft Active Directory).  When I inspect the traffic to the LDAP repository, I am able to see that a connection is established but authentication fails saying that the BindName is NULL.

    If I connect to the same repository with Softerra LDAP browser with the same credentials, I am able to successfully connect and interact with the repository.

    So my question is, can SiteFinity connect to Novell eDirectory and if so, what setting could I be missing that results in the BindName coming through as NULL.  What property in the configuration of LDAP settings in SIteFinity would map to the BindName property when connecting.  As I say, using the same credentials from Softerra LDAP browser works and the BindName property is appropriately populated when i inspect the LDAP repository traffic?

    Thanks
    Bradley
  4. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    Registered:
    01 Feb 2016
    17 Oct 2011
    Link to this post
    Hi Bradley,

    Can you please let us know what is the Bind name used for in eDirectory. Basically you should be able to map the needed fields for users and roles by going to Administration -> Settings -> Advanced -> Security -> LDAP Settings -> LDAP Mapping.

    Best wishes,
    Radoslav Georgiev
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  5. Bradley
    Bradley avatar
    3 posts
    Registered:
    11 Oct 2011
    18 Oct 2011
    Link to this post
    Hi Radoslav

    I am not sure exactly what eDirectory uses the bind name for. What I do know is that when I connect from Softerra LDAP browser that property is populated, when trying to connect via SF, it is not.

    I have been to  Administration -> Settings -> Advanced -> Security -> LDAP Settings -> LDAP Mapping
    and configured all the mappings but still no luck.

    Another colleague of mine has also been speaking to Alexander Rakshiev to try to solve this.  I am not sure if you guys work in proximity to each other and between you could help us?

    I believe Duncan (my colleague) is going to try to give Alexander remote access to the site to try to look at our configuration to see if there is anything we are missing....

    Regards
    Bradley
  6. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    Registered:
    01 Feb 2016
    19 Oct 2011
    Link to this post
    Hi Bradley,

    Yes I have been notified about the request to Alex. As far as I know you are going to set up a sandbox for us to which we can connect from here and try to set up the eDirectory provider. From looking at the issue now I seems that it is not related to the mapping, as it seems that the request does not reach the part where it should get users, it seems that it fails on the connection itself.

    Greetings,
    Radoslav Georgiev
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
6 posts, 0 answered