More in this section

Forums / General Discussions / IIS Authentication Issue

IIS Authentication Issue

10 posts, 0 answered
  1. Tarun
    Tarun avatar
    81 posts
    Registered:
    14 Jan 2009
    11 May 2011
    Link to this post
    Hi,

    I hosted a sitefinity 4.1 site on server 2003, iis6.0. The site seems work but when I tried to edit Pages in admin then its give me below error

    exception message is: IIS specified authentication schemes 'IntegratedWindowsAuthentication, Anonymous', but the binding only supports specification of exactly one authentication scheme. Valid authentication schemes are Digest, Negotiate, NTLM, Basic, or Anonymous. Change the IIS settings so that only a single authentication scheme is used.

    I checked both below link but did not work
    http://www.sitefinity.com/devnet/forums/sitefinity-4-x/general-discussions/iis-authentication-modes.aspx
    http://www.sitefinity.com/devnet/forums/sitefinity-4-x/general-discussions/4-0-installation-quirks.aspx

    Please could you suggest me what settings need to be set for sitefinity 4.1 to work on server 2003 with iis6.

    I am looking forward for an urgent response.

    Thanks,
    Tarun
  2. Greg
    Greg avatar
    82 posts
    Registered:
    08 Aug 2012
    11 May 2011
    Link to this post
    Hi Tarun -

    Here is a screenshot of how I have IIS6 setup - you need to make sure 'Integrated Windows Authentication' is unchecked.

    Greg
  3. Tarun
    Tarun avatar
    81 posts
    Registered:
    14 Jan 2009
    11 May 2011
    Link to this post
    Hi Greg,

    I have already checked that but not working. I have checked almost all solution provided on that two links.

    See attached of my iis screenshot.

    Thanks,
    Tarun


  4. Greg
    Greg avatar
    82 posts
    Registered:
    08 Aug 2012
    11 May 2011
    Link to this post
    Whoops, sorry for missing that! The only other thing I have to do when using IIS6 is update the hosts file (C:\Windows\System32\drivers\etc\) to have something like: 127.0.0.1 sitename

    Try this, save your hosts file, and retry going to pages.
  5. Tarun
    Tarun avatar
    81 posts
    Registered:
    14 Jan 2009
    11 May 2011
    Link to this post
    Thank you Greg for replying soon!

    I made below combination of changes in hosts file one viz one but did not work.

    1.   127.0.0.1       icelandhotels

    2.   127.0.0.1       icelandhotels.us

    3.   127.0.0.1       localhost
          127.0.0.1       icelandhotels.us

    I am attaching the screenshot of issue please check that.

    Please help me out.

    Regards,
    Tarun
  6. Greg
    Greg avatar
    82 posts
    Registered:
    08 Aug 2012
    11 May 2011
    Link to this post
    Hm...okay. I'm assuming you are using icelandhotels.us as your host header to match the hosts file. So, just to eliminate this, did you try restarting website and app pool to test?

    The other changes / configs in IIS6 need to be:

    1) Wildcard mapping in application configuration (see attached)
    2) My app pool is set to use Network Service
    3) I gave the NETWORK SERVICE user account modify rights to my App_Data folder (windows permissions)

    Beyond this, I'm stumped!

    Greg
  7. Tarun
    Tarun avatar
    81 posts
    Registered:
    14 Jan 2009
    12 May 2011
    Link to this post
    Hi,

    I made every changes you suggested but still getting same error on add/edit contents/pages.

    Thanks,
    Tarun
  8. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    12 Sep 2017
    13 May 2011
    Link to this post
    Hello Tarun,

    The initial error indicates that you have two authentication types enabled, since you should disable one of them. Please check our installation guide

    Best wishes,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  9. Tarun
    Tarun avatar
    81 posts
    Registered:
    14 Jan 2009
    15 May 2011
    Link to this post
    Hi,

    I have selected only checked anonymous access checkbox rest of are unchecked as I have attached a screenshot with earlier post. I rechecked everything according to your given link but still getting error.

    Can I share my screen with you so you guys can take a look too there?

    Thanks,
    Tarun
  10. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    12 Sep 2017
    16 May 2011
    Link to this post
    Hello Tarun,

    Can you replicate this issue on another machine (VM or another server)? It looks like that you have an infrastructure issue.

    Best wishes,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
10 posts, 0 answered