More in this section

Forums / General Discussions / Images - simple list template edit

Images - simple list template edit

2 posts, 0 answered
  1. Amanda Shafer
    Amanda Shafer avatar
    198 posts
    Registered:
    12 Oct 2012
    28 Jun 2011
    Link to this post
    Hello,
    I want to change my simple list template for the image gallery to use the template below. However, whenever I try to remove the       <sf:SitefinityHyperLink runat="server" id="singleItemLink" /> I get an "error parsing template".  Can anyone tell me how to get rid of that error or a better way to edit the template?

    <%@ Control Language="C#" %>
    <%@ Register TagPrefix="sf" Namespace="Telerik.Sitefinity.Web.UI.ContentUI" Assembly="Telerik.Sitefinity" %>
    <%@ Register TagPrefix="sf" Namespace="Telerik.Sitefinity.Web.UI" Assembly="Telerik.Sitefinity" %>
    <%@ Register TagPrefix="sf" Namespace="Telerik.Sitefinity.Web.UI.PublicControls.BrowseAndEdit" Assembly="Telerik.Sitefinity" %>
    <%@ Register TagPrefix="telerik" Namespace="Telerik.Web.UI" Assembly="Telerik.Web.UI" %>
     
     
     
     
    <sf:BrowseAndEditToolbar ID="browseAndEditToolbar" runat="server" Mode="Edit"></sf:BrowseAndEditToolbar>
    <telerik:RadListView ID="ItemsList" ItemPlaceholderID="ItemsContainer" runat="server" EnableEmbeddedSkins="false" EnableEmbeddedBaseStylesheet="false">
    <LayoutTemplate>
        <div id="slider-wrapper">
    <img src="/resources/SeeWhat.png" alt="See What PNA Can Do For You" id="slider-wrapperhdr" />
    <div id="slider" class="nivoSlider">
          <asp:PlaceHolder ID="ItemsContainer" runat="server"/>
        </div>
    </div>
      </LayoutTemplate>
      <ItemTemplate>
        <a href="<%# Eval("Hyperlink")%>">
          <img src="<%# Eval("MediaUrl")%>"  title="<%# Eval("AlternativeText")%>"   />
        </a>
      </ItemTemplate>
    </telerik:RadListView>
     
     
     
    <sf:Pager id="pager" runat="server"></sf:Pager>
  2. Amanda Shafer
    Amanda Shafer avatar
    198 posts
    Registered:
    12 Oct 2012
    28 Jun 2011
    Link to this post
    After a bit more playing, I got it to work. I kept the Hyperlink tag and set the NavigateURL to my custom field. Then I modified the Nivo script to use alt instead of title.
2 posts, 0 answered