More in this section

Forums / General Discussions / Layout issue after upgrading to Q1

Layout issue after upgrading to Q1

10 posts, 0 answered
  1. AmrElsayed
    AmrElsayed avatar
    87 posts
    Registered:
    18 Jul 2012
    21 Apr 2011
    Link to this post
    Hi,

    We have a master page on our website with three contentplaceholders, and we created a sitefinity template based on this master page.
    In the template, we dragged the navigation widget in the top content place holder, and a generic content for the footer of the website in the bottom placeholder.
    When we upgraded from SP1 to Q1 we got an issue, that all the pages which are based on this template have a duplication for the navigation menu, also a duplication for some text from the master page.

    Please refer to the attached image. 

    Thanks
  2. Phill Hodgkinson
    Phill Hodgkinson avatar
    362 posts
    Registered:
    10 Nov 2004
    22 Apr 2011
    Link to this post
    @AmrElsayed, I don't have any answers for you but just so you know you're not the only one having this issue. I'm also having an issue with content mysteriously being duplicated into other place holders. It seems to add to place holders at the bottom of the page, the last place holder actually. In my case the content that is magically appearing was actually deleted a while ago and belongs to an old page revision that has since been deleted. A real mystery and the only solution is to delete pages and create from scratch (which isn't a solution since it's a live site with lots of content).

    Hope a fix is on it's way!

    Phill
  3. George
    George avatar
    23 posts
    Registered:
    24 Apr 2005
    24 Apr 2011
    Link to this post

    I am having a similar issue.  I have a home page, which currently has no widgets.  I planned on dealing with it later.  Back in February, I dropped a content widget on with some default text, just as a placeholder.  I had deleted the widget from the page shortly after.

    After the upgrade to 4.1, the widget shows once again in my home page.  Here's the rub, when I go to the page, it shows that there are no widgets on the page.  The only way to cure the problem was to delete the page entirely and recreate it.

    Thanks, Greg
  4. ZK
    ZK avatar
    23 posts
    Registered:
    23 Nov 2010
    25 Apr 2011
    Link to this post
    Just wanted to ditto this problem. Our event calendar page shows the events widget in both content place holders, even though it has never been in the 2nd one.
  5. Pavel Iliev
    Pavel Iliev avatar
    140 posts
    Registered:
    18 Jul 2016
    27 Apr 2011
    Link to this post
    Hi Zak,

    Please, take a look at this forum post http://www.sitefinity.com/devnet/forums/sitefinity-4-x/general-discussions/all-data-on-entire-site-lost-after-master-page-template-changed.aspx. It should resolve your issue. Still before running it make sure to backup your database.


    Kind regards,
    Pavel
    the Telerik team

  6. ZK
    ZK avatar
    23 posts
    Registered:
    23 Nov 2010
    27 Apr 2011
    Link to this post
    Unfortunately this had no noticeable effect.
  7. Steve
    Steve avatar
    3037 posts
    Registered:
    03 Dec 2008
    27 Apr 2011
    Link to this post
    Did nothing for me as well...
  8. Pavel Iliev
    Pavel Iliev avatar
    140 posts
    Registered:
    18 Jul 2016
    02 May 2011
    Link to this post
    Hello Steve,

    We fixed the issue in the forthcoming internal build. Is it going to be a solution for you?

    Regards,
    Pavel
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  9. ZK
    ZK avatar
    23 posts
    Registered:
    23 Nov 2010
    02 May 2011
    Link to this post
    I've been trying to go into production for close to two months, so an internal build isn't much of a solution to me. I need something supported that I can take live. Don't know about the rest of these fellas...
  10. Steve
    Steve avatar
    3037 posts
    Registered:
    03 Dec 2008
    02 May 2011
    Link to this post
    By this point...I don't care...I'll take anything as long as I don't have to re-create EVERY page in my project

    Bring on the internal
10 posts, 0 answered