More in this section

Forums / General Discussions / unable to save pages, etc. - error message

unable to save pages, etc. - error message

11 posts, 0 answered
  1. NuToSitefinity
    NuToSitefinity avatar
    140 posts
    Registered:
    01 Sep 2010
    09 Mar 2011
    Link to this post
    We deployed our sitefinity app to our actual dev server and now we can't publish pages, save pages, etc.
    I get the following error message:

    There was no endpoint listening at http://dev.myMarketplace/DefaultWorkflows/PagesApprovalWorkflow.xamlx that could accept the message.
    This is often caused by an incorrect address or SOAP action. See InnerException, if present, for more details.”

    any suggestions on what is causing this? I can create new pages, templates, etc, but get the error message and I can't publish the new page, etc
  2. NWTResearch
    NWTResearch avatar
    24 posts
    Registered:
    04 Apr 2005
    09 Mar 2011
    Link to this post
    Did you see this post? http://www.sitefinity.com/devnet/forums/sitefinity-4-x/general-discussions/no-endpoint-for-anymediacontentapprovalworkflow.aspx. Might help in your situation.

    **update- whoops, sorry I see that you did see that post already*
  3. NuToSitefinity
    NuToSitefinity avatar
    140 posts
    Registered:
    01 Sep 2010
    10 Mar 2011
    Link to this post
    yes I did, and nothing mentioned helped my situation.
  4. Victor Velev
    Victor Velev avatar
    1345 posts
    Registered:
    06 Jul 2015
    10 Mar 2011
    Link to this post
    Hello CsharpGuy,

    Could you please give us some more information about your project - is it running on IIS or VS integrated web server or the Project Manager's integrated web server? Can you please let us know how your IIS is set up if you are running the site there and you have any restrictions on accessing the outside world form the host machine.


    Kind regards,
    Victor Velev
    the Telerik team
  5. NuToSitefinity
    NuToSitefinity avatar
    140 posts
    Registered:
    01 Sep 2010
    10 Mar 2011
    Link to this post
    I installed it a  web site. I copied the needed files from my dev machine to my server and set it up under IIS as a web site. I can access everything but can't publish, save, etc.

    I have the site setup under a folder and setup the site under IIS to point to that folder. the site is running under a port number and not the port 80

  6. Victor Velev
    Victor Velev avatar
    1345 posts
    Registered:
    06 Jul 2015
    10 Mar 2011
    Link to this post
    Hi NWTResearch,

    Thank you for getting back to me.

     The problem with IIS is that the request from outside may come for one location but internally it is forwarded to another and then Sitefinity does not know where exactly the default workflows are. Also another case for this issue is if for example the VPS you are hosting the website has restrictions on outbound traffic.

    You can try and take your DB from your PC where it is working and copy the configs except the DataConfig.config and try to run it again.

    If this solution does not help can you please share a little bit more how the project is set up on your local VS?

    Best wishes,
    Victor Velev
    the Telerik team
  7. NuToSitefinity
    NuToSitefinity avatar
    140 posts
    Registered:
    01 Sep 2010
    10 Mar 2011
    Link to this post
    that solution didn't work. Right now the project is setup in two locations on my local

    1. setup in a folder for development purposes such as (c:\mysites\clientnumber1) I open sitefinity run the admin portion of it, edit in VS, etc and its fine.

    when I want to test it under an IIS environment, I then move it to my clientnumber1 folder under inetpub/wwwroot folder and I'm able to save pages, publish pages, etc with no problem.

    On my server, I have the site setup as a virtual on so its point to c:\sites\clientnumber1 and my IIS set is pointing to that, so I access it as http://dev.clientnumber1.com:100/ and I can't save, publish, etc, only view

    Do I need to run the site under inetpub/wwwroot directory on my server as well for everything to work correctly and do I need to remove the port number and just have it as http://dev.clientnumber1.com?

    My local environment is running Windows 7, IIS7
    my server is windows 2008 server, IIS7



  8. Victor Velev
    Victor Velev avatar
    1345 posts
    Registered:
    06 Jul 2015
    11 Mar 2011
    Link to this post
    Hello NWTResearch,

    Are you sure you made all the necessary redirections and settings in IIS, because it seems to be some misunderstanding between IIS and Sitefinity. Can you create a new project on your live server by creating a web site in IIS then browsing to it from Sitefinity Project Manager and check if you have the needed permissions.

    Regards,
    Victor Velev
    the Telerik team
  9. Allen
    Allen avatar
    71 posts
    Registered:
    04 Aug 2007
    02 Apr 2011
    Link to this post
    I was experiencing the same issue and none of the suggestions worked.  Our scenario was that I had a web server with multiple sites.  We used a common, internal IP for our server and I had a host-header set up for the site.  Additionally, our domain name was registered elsewhere and had to use the external IP.  However, internally, we had a different IP. What wound up working for me was adding an entry to the HOSTS file for the internal IP and RESTARTING IIS.  After doing that, and setting the services path, everything worked.  Hope this helps.
  10. Assid
    Assid avatar
    1 posts
    Registered:
    01 Jul 2008
    06 Jun 2011
    Link to this post
    Hi
    I am having the same issue with my project. I am using Sitefinity 4.1.1339.0 and Windows Server 2003 . I can edit the page from the admin side, but when I try to publish the changes, I get this error "There was no endpoint listening athttp://beta.q-principle.com/DefaultWorkflows/PagesApprovalflow.xamlx that could accept the message. This is often caused by an incorrect address or SOP action. See InnerException, if present, for more details."
    I set the WorkflowBaseUrl to "http://beta.q-principle.com" and still have the same issue. 

    Any idea how I can fix this?
  11. Victor Velev
    Victor Velev avatar
    1345 posts
    Registered:
    06 Jul 2015
    07 Jun 2011
    Link to this post
    Hello Assid,

    When you set your WorkflowBaseUrl please make sure to write your top level domain, for example " http://q-principle.com "

    The problem with it is that the request from outside may come for one location but internally it is forwarded to another and then Sitefinity does not know where exactly the default workflows are.

    You can also check the following article:

    http://www.sitefinity.com/devnet/forums/sitefinity-4-x/general-discussions/failed-workflow-operation.aspx

    Can you try to make domain mapping for the domain into the server hosts file, and then pointed them to the "localhost" address. Are you getting this error if you use our ProjectManager to run the website or you use Visual Studio built-in web server?

    Kind regards,
    Victor Velev
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
11 posts, 0 answered